JS CTypes has a build dependency bug

RESOLVED FIXED

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: sayrer, Assigned: dwitte)

Tracking

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 beta1+)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Last night, I merged two perfectly green trees, TM and M-C, and got tons of CTypes crashes in jsdtoa.cpp.

After a clobber, it was all fine.

Comment 1

9 years ago
Robert,

So are you saying that landing patch part 2 or bug# 549532 should be fine after a "clobber"? Please explain what a clobber is...Thanks.

Mike M.
(Assignee)

Comment 2

9 years ago
That is... very strange.

I'm not sure if I'll be able to tell anything from the logs, but I'll look.
(Assignee)

Comment 3

9 years ago
Confirmed. On a hunch I touched jsdtoa.h and rebuilt; the ctypes objects don't get remade.

I think the js/src/Makefile.in just needs more VPATH.
(Assignee)

Comment 4

9 years ago
(This also explains why I could never reproduce it in my local debugging. Yay dependency bugs!)
(Assignee)

Comment 5

9 years ago
Created attachment 441388 [details] [diff] [review]
patch

This looks like it fixes it. Clobbering works; make clean && make works; touch jsdtoa.h && make works.

Tryserver's chewing on it now, to make sure it doesn't break any existing dep builds.
Attachment #441388 - Flags: review?(sayrer)
(Assignee)

Comment 6

9 years ago
Note that this will result in orphaned obj files in js/src/ctypes, but they're harmless and will be cleaned up on the next clobber.
(Reporter)

Updated

9 years ago
Attachment #441388 - Flags: review?(sayrer) → review+
(Reporter)

Comment 7

9 years ago
(In reply to comment #1)
> Robert,
> 
> So are you saying that landing patch part 2 or bug# 549532 should be fine after
> a "clobber"? Please explain what a clobber is...Thanks.

A clobber is when we delete all existing object files and rebuild everything from scratch. Your patch just touched lots of files, so tickled this bug. After dwitte's fix lands, it should be clean.

Comment 8

9 years ago
That explains why dtoa.c still crashed after backing out my patch.
Blocks: 560358
(Assignee)

Comment 10

9 years ago
Pushed to tracemonkey.

Apologies to everyone who spent time looking at this; it went unfound for too long. I'm glad it was finally nailed down.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 559056
You need to log in before you can comment on or make changes to this bug.