Layout problem at kodak's site

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P1
critical
VERIFIED FIXED
18 years ago
3 years ago

People

(Reporter: Chris Petersen, Assigned: bc)

Tracking

Details

(Whiteboard: [rtm-], URL)

(Reporter)

Description

18 years ago
Build: 2000101108
Platform: All
Expected result: Page's content should be aligned in table properly.
What I got: Portion of JS code flows into table and causes layout problem.
Steps to reproduce:

1) Go to www.kodak.com.
2) Notice the content in the middle of table is completely misaligned.
3) JS code appears in this part of the table and is causes the layout problem.
(Reporter)

Comment 1

18 years ago
Nominating rtm.
Keywords: rtm

Comment 2

18 years ago
They have a </SCRIPT> tag in the JS code. They have attempted to escape it as 
</SCRIPT\> (instead of <\/SCRIPT>. However, I don't think that will stop the 
tag being parsed. Breaks NN classic and W3C validator too. 

Fixing the tag markedly improves a copy of the page offline.

Anyone want to verify and bounce it to Kodak?

(Reporter)

Comment 3

18 years ago
Requesting a triage on this bug. It's nominated but doesn't have a - or +. Are
we going to fix this for rtm ?

Comment 4

18 years ago
Reassigning to ekrock, cc-ing harishd, rickg. I doubt this will get fixed, but 
maybe ekrock can contact Kodak.
Assignee: clayton → ekrock
Priority: P3 → P2
[rtm-]. Bad markup on page, not product problem. --> Evangelism.
Assignee: ekrock → blakeross
Component: Layout → Evangelism
QA Contact: petersen → zach
Whiteboard: [rtm-]

Comment 6

18 years ago
The problem with the page is that there is script that essentially does a 
document.write('</SCRIPT>') without escaping the <SCRIPT>. Rewriting the page to 
be document.write('<\/SCRIPT>') fixes the problem.

Updated

18 years ago
Severity: major → critical
Status: NEW → ASSIGNED
Priority: P2 → P1
Target Milestone: --- → mozilla0.6

Comment 7

18 years ago
*** Bug 58641 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Status: ASSIGNED → NEW
(Reporter)

Comment 9

18 years ago
As of 11/28, this problem is still occuring in N6. Has contact been made with
Kodak to address this problem ?

Updated

18 years ago
Target Milestone: mozilla0.6 → Future

Comment 10

17 years ago
Assigning to Netscape Technology Evangelim team. For further info, send mail to
devsupport@netscape.com.

Comment 11

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
i don't see the javascript problem in the page. marking fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

17 years ago
The original problem has been fixed for some time now. Marking verified.
Status: RESOLVED → VERIFIED
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Target Milestone: Future → ---
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.