Last Comment Bug 561659 - Listitem does not appear, after collapse/expand scolled listbox
: Listitem does not appear, after collapse/expand scolled listbox
Status: RESOLVED WORKSFORME
: regression, testcase
Product: Core
Classification: Components
Component: XP Toolkit/Widgets: XUL (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
Mentors:
Depends on: 584703
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 13:36 PDT by Alice0775 White
Modified: 2010-10-15 01:09 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
final+


Attachments
testcase (913 bytes, application/vnd.mozilla.xul+xml)
2010-04-25 13:39 PDT, Alice0775 White
no flags Details

Description Alice0775 White 2010-04-25 13:36:44 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100425 Minefield/3.7a5pre ID:20100425040736
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100425 Minefield/3.7a5pre ID:20100425040736

Listitem does not appear, after collapse/expand scolled listbox

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with "NEW profile".
2. Install https://addons.mozilla.org/en-US/firefox/addon/2324 (This extention added listitem to "Clear Recent History" dialog.). And restart.
3. Tools > Clear Recent History...
4. Collapse and Expand listbox by click small buttom.
5. Scroll to bottom of listbox.
6. Collapse and Expand listbox by click small buttom.

Actual Results:
 item(Browsing & Download History) is missing,

Expected Results:
 No item is missing.

Regression Window:
Works:
http://hg.mozilla.org/mozilla-central/rev/f86035589b4d
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100328 Minefield/3.7a4pre ID:20100328090648

Fails:
http://hg.mozilla.org/mozilla-central/rev/6f80d1746d80
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100328 Minefield/3.7a4pre ID:20100328193141

PushLog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f86035589b4d&tochange=6f80d1746d80
Comment 1 Alice0775 White 2010-04-25 13:39:18 PDT
Created attachment 441397 [details]
testcase

Steps to Reproduce:
1. Scroll to bottom of listbox.
2. Collapse and Expand listbox by click expander button.

Actual result:
Items are missing.
Comment 2 Alice0775 White 2010-04-25 13:40:47 PDT
(In reply to comment #0)
Spell miss!
s/click small buttom./click small button./g
Comment 3 Boris Zbarsky [:bz] (TPAC) 2010-04-26 06:07:12 PDT
roc, looks like a regression from one of your changes...
Comment 4 Timothy Nikkel (:tnikkel) 2010-10-15 00:48:27 PDT
I retested this, it seems to be fixed now. (Testing this now requires some way of loading xul files now that it is disabled.)
Comment 5 Alice0775 White 2010-10-15 01:07:30 PDT
I confirmed. It was fixed.

Fixed range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6baaadf1ddd0&tochange=e560e0fe90d1
Comment 6 Timothy Nikkel (:tnikkel) 2010-10-15 01:09:24 PDT
Thanks for the fixed range!

From that range looks like probably bug 584703 fixed this.

Note You need to log in before you can comment on or make changes to this bug.