Closed Bug 561787 Opened 11 years ago Closed 11 years ago

Fix GCC warnings in gfx/qcms/iccread.c: "incompatible implicit declaration of built-in function ‘memcpy’"

Categories

(Core :: GFX: Color Management, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: dholbert, Assigned: dholbert)

References

()

Details

(Whiteboard: [build_warning])

Attachments

(1 file)

Attached patch fixSplinter Review
{
> gfx/qcms/iccread.c: In function ‘read_u32’:
> gfx/qcms/iccread.c:90: warning: implicit declaration of function ‘memcpy’
> gfx/qcms/iccread.c:90: warning: incompatible implicit declaration of built-in function ‘memcpy’
> gfx/qcms/iccread.c: In function ‘read_u16’:
> gfx/qcms/iccread.c:102: warning: incompatible implicit declaration of built-in function ‘memcpy’
}

This warning stood out to me in my console-spew, since mistakes with memcpy can be bad. It turns out to be non-scary and trivial to fix -- we're just missing an #include. Attached patch fixes this.
Attachment #441523 - Flags: review?(roc)
http://hg.mozilla.org/mozilla-central/rev/98749d6edaa5
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 562575
Whiteboard: [build_warning]
You need to log in before you can comment on or make changes to this bug.