Firefox hangs at hard-working flash scripts

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Matthias, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

If a flash script is calculating intensive you can't use Firefox until the script has finished.
(I tried it at the social game "FarmVille". During the loading screen of a friend's farm, I can't navigate to other open browser tabs.)

Is it possible to ran scripts like flash or java winthin a separate thread so that firefox will always be usable?

Reproducible: Always

Comment 1

8 years ago
Plugins will run in a separate process in Firefox 3.6.4

https://developer.mozilla.org/devnews/index.php/2010/04/08/firefox-lorentz-beta-available-for-download-and-testing/

This is mainly done for stability (when a plugin crashes, the browser stays running), but it should also help performance a bit, since it avoids the single-threaded design of the browser/plugin interface (which is very hard to change). Further work will be done in later releases when content from different tabs will also run in different processes.

On the other hand .. all these separate processes or threads also introduce extra delay ...
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.