Half the contribute button is missing background color in RTL (Arabic)

VERIFIED FIXED in 5.10

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: krupa, Assigned: craigcook)

Tracking

unspecified
5.10
x86
Mac OS X

Details

(Whiteboard: [z][button], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 441530 [details]
screenshot

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

steps to reproduce:
1.Go to https://preview.addons.mozilla.org/ar/firefox/addon/2410/
2.Notice the contribute button

observed behavior:

Half the contribute button is missing background color in RTL (Arabic)

(The overlap of contribute and install button is filed as a separate bug)
I think Craig fixed this somewhere else.  Way to go Craig!
Assignee: nobody → craigcook.bugz
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

8 years ago
This is not fixed yet

https://preview.addons.mozilla.org/he/firefox/addon/2410/
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 3

8 years ago
This is bug 554592 rearing its ugly head again. It's the combination of declaring RTL for the document, then including text in a LTR language, plus the empty <b></b> for the icon. The browser really wants to treat that empty <b></b> as RTL (since it contains no text and the document-wide RTL is in effect). But right next to it is a word in English which has inherent LTR directionality. So the text is LTR but the icon is RTL and they're just not flowing properly.

If the text is in a RTL language the problem goes away, so probably the most ideal solution is to localize the button. Failing that, we could still hide the icon, which also evades the bad rendering but is a less ideal workaround (we lose the cool icon but at least the button looks whole).
Works for me.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.