SunOS - Segmentation Fault - (firefox-bin:6218): GLib-WARNING **: g_set_prgname() called multiple times

RESOLVED WONTFIX

Status

()

Firefox
General
--
major
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Rob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.2.3) Gecko/20100403 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.2.3) Gecko/20100403 Firefox/3.6.3

$ uname -a
SunOS opensolaris 5.11 snv_134 i86pc i386 i86pc Solaris

I have ran the "Update Manager", the OS is updated.

Launching it from the Menu Entry that I created works fine as I am able to enter this BR :) .


Reproducible: Always

Steps to Reproduce:
1. Click 'Root Terminal' (actually it does not have that much permission).
2. Fetch, Install, mozilladeveloperpreview-3.7a4.en-US.opensolaris-i386.tar.bz2 [see below]
3. $ /opt/sfw/lib/firefox_nightly/firefox

(firefox-bin:6218): GLib-WARNING **: g_set_prgname() called multiple times
Segmentation Fault (core dumped)
user@opensolaris:~$



Get mozilladeveloperpreview-3.7a4.en-US.opensolaris-i386.tar.bz2 here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/3.7a4-candidates/build1/contrib/solaris_tarball/

Actual Results:  
Segmentation Fault

Expected Results:  
No Segmentation Fault

In 'theory' a "Segmentation Fault" can never occur; if it does that's a Bug. [TM]
(Reporter)

Comment 1

8 years ago
Segmentation Fault is present in 3.6.3 20100403, and absent in:

Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.3a4) Gecko/20100409 MozillaDeveloperPreview/3.7a4

I still get the "g_set_prgname() called multiple times" warning in 3.7a4 with 20100409 .

Rob

Comment 2

8 years ago
Please attach the "pstack core" result.

The warning is a bug of GNOME library, not Firefox.

You can try this workaround:
export GTK_IM_MODULE=xim
firefox

If it solved the problem, it is a known issue.

Updated

8 years ago
Whiteboard: [needs more info from the reporter] [closeme 2010-06-01]
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Please attach the "pstack core" result.
> ...
Next time I have access to OpenSolaris I will try your advice. I have also reported this here: https://defect.opensolaris.org/bz/show_bug.cgi?id=15771

Rob
(Reporter)

Comment 4

8 years ago
(In reply to comment #2)
> Please attach the "pstack core" result.
> 


user@os2010:~/tmp$ wget http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/contrib/2010-05-14-04-mozilla-central/firefox-3.7a5pre.en-US.solaris2.11-i386.tar.bz2
user@os2010:~/tmp$ gtar -jxf firefox-3.7a5pre.en-US.solaris2.11-i386.tar.bz2
user@os2010:~/tmp$ pfexec mv firefox /usr/lib/firefox-3.7a5pre
user@os2010:~/tmp$ /usr/lib/firefox-3.7a5pre/firefox &
(firefox-bin:2529): GLib-WARNING **: g_set_prgname() called multiple times
[1]+  Segmentation Fault      (core dumped) /usr/lib/firefox-3.7a5pre/firefox

user@os2010:~/tmp$ pstack core.firefox-bin.2529 
core 'core.firefox-bin.2529' of 2529:	/usr/lib/firefox-3.7a5pre/firefox-bin
 feee4697 _lwp_kill (1, b, 8046c68, fee8bb6e) + 7
 fee8bb7a raise    (b, 8046c80, 0, fd16727e) + 22
 fd16737a __1cNnsProfileLockSFatalSignalHandler6FipnHsiginfo_pv_v_ (b, 8046f7c, 8046d7c, ffff, fee02a00, fef72000) + 10a
 feedfdb5 __sighndlr (b, 8046f7c, 8046d7c, fd167270) + 15
 feed2d0f call_user_handler (b) + 2af
 feed2f52 sigacthandler (b, 8046f7c, 8046d7c) + f2
 --- called from signal handler with signal 11 (SIGSEGV) ---
 f9849384 ???????? (87e1568, 0, 2, 86e4278, 8047178, 0)
 fc1cf65e g_closure_invoke (87e1568, 0, 2, 86e4278, 8047178, ffffffff) + d6
 fc1e5c50 signal_emit_unlocked_R (80885d8, 0, 80a0000, 0, 86e4278, 80a0000) + d94
 fc1e4aac g_signal_emit_valist (80a0000, 3, 0, 804736c) + 9c8
 fc1e4cad g_signal_emit (80a0000) + 25
 fbb64bba gdk_display_close (80a0000, fedc0870, 80473a8, fd159aef) + 4e
 fd159b19 __1cVMOZ_gdk_display_close6FpnL_GdkDisplay__v_ (80a0000, 8047590) + c9
 fd15bee1 XRE_main (1) + 2375
 08051e1c main     (1, 804784c, 8047854, 8047840) + 25c
 08051afd _start   (1, 8047984, 0, 80479aa, 80479d8, 80479fd) + 7d
user@os2010:~/tmp$ 


Thanks,
Rob
(Reporter)

Updated

8 years ago
Whiteboard: [needs more info from the reporter] [closeme 2010-06-01] → [Reporter added info][needs more info from the reporter] [closeme 2010-06-01]

Comment 5

8 years ago
It is a known issue of iiim, it will be fixed in future release.

See:
http://defect.opensolaris.org/bz/show_bug.cgi?id=12024

Technically, it is not a bug of Firefox, and we don't want to apply a workaround in Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
Whiteboard: [Reporter added info][needs more info from the reporter] [closeme 2010-06-01]
You need to log in before you can comment on or make changes to this bug.