moz-icon fails to display the right icon for application/gzip content-type on Linux (and others!)

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: protz, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.4) Gecko/20100413 Firefox/3.6.4
Build Identifier: 

The following URL schemes fail (display the default icon instead of the right one):
moz-icon://blah?size=16&contentType=application/gzip
moz-icon://.zip?size=16
moz-icon://.xpi?size=16

The surprising part is that this one works!
moz-icon://blah?size=16&contentType=application/zip

I thus believe this bug is a low hanging fruit only waiting to be fixed ;-).

Pascal also reported similar issues in bug 545532

Using an up-to-date Debian Testing with the Tango Gnome Icon Theme.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Going through my bugs, seeing no activity on this one, CCing extra people because I probably filed into the wrong component, please help me CC more people / change components. Thanks!
Status: UNCONFIRMED → NEW
Component: ImageLib → Graphics
Ever confirmed: true
QA Contact: imagelib → thebes
(Reporter)

Comment 2

8 years ago
CCed the wrong Neils, sorry for the confusion

Updated

8 years ago
Component: Graphics → ImageLib
QA Contact: thebes → imagelib
Could this be closed as a duplicate of Bug 545532 ?
Blocks: 599904

Comment 4

8 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre Gentoo

Nightly from Mozilla and not homebaked.


The following displays the generic icon:
moz-icon://.xpi?size=128
moz-icon://blah?size=128&contentType=application/gzip
moz-icon://blah?size=128&contentType=application/tar

The following displays the correct icons:
moz-icon://.zip?size=128
moz-icon://blah?size=128&contentType=application/zip
moz-icon://.tar?size=128
moz-icon://blah?size=128&contentType=application/x-tar

The following displays the generic archive icon:
moz-icon://.gz?size=128
moz-icon://blah?size=128&contentType=application/x-gzip


So... is it possible to fall back to category/x-type when category/type does not exist, if that is the real problem? Perchance is the bug invalid as application/gzip should be supplied by the dist/theme?
Note that application/zip is a registered MIME type: http://www.iana.org/assignments/media-types/application/zip

application/gzip is not.  It does not appear on <http://www.iana.org/assignments/media-types/application/index.html>.  Hence the use of application/x-gzip as the type of gzip, pending someone registering a type for them....  Similar for x-tar vs tar.

So I'm not sure it makes sense for the theme to supply icons for these nonexistent MIME types.

Whether it makes sense for us to fix them up... not sure.
Testing under Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0 on Ubuntu 11.04, these work fine:
moz-icon://blah?size=64&contentType=application/x-gzip
moz-icon://.gz?size=64
moz-icon://.tar.gz?size=64

What is causing the application/gzip mime to appear in your browser ?
I'm pretty sure that this is all handled by the distro/theme/OS. I also don't see a good reason to want to fall back to application/x-foo when application/foo doesn't exist, though I wouldn't necessarily reject a patch to do that.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.