Deleting folders on IMAP does not work with some IMAP servers

RESOLVED WORKSFORME

Status

MailNews Core
Backend
P3
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: urracht, Unassigned)

Tracking

({imap-interop})

Trunk
x86
Linux
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 2008-05-17 dupeme)

(Reporter)

Description

18 years ago
Deleting folders on IMAP, specifically, the fact that it deletes them by moving
them to the trash can, does not work with some IMAP servers.

For example, the imap server that comes with RedHat 6.2 (imap-4.7-5.rpm) uses
directories to represent folders.  Therefore a folder can either contain
messages (i.e. it is a text file) or other folders (i.e. it is a directory).

The ``Trash'' folder is a text file.  Therefore, when you delete some other
folder, it tries to create ``Trash/OtherFolder'', but the name Trash is already
used by the text file.

Mozilla should have a preference for this, or better yet, detect this and
recover gracefully (``Mozilla cannot move this folder to the Trash.  Would you
like to delete it permanently -- WARNING: All Messages Will Be Lost?'').

Steven
Confirming due to my assessment of the sanity of the reporter :-)

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: esther → huang

Comment 2

17 years ago
Reporter is this still a problem in the latest nightlies?
Keywords: interop
(Reporter)

Comment 3

17 years ago
I just tried it on March 13/2001 (Mozilla/5.0 (X11; U; Linux 2.2.17-14 i686;
en-US; 0.8.1) Gecko/20010313), and it still occurs.

Comment 4

17 years ago
To owner attention. It is not a bug at the moment. Mozilla just was not properly
configured. There is an option in Edit->Mail/News Account Settings->Server
Settings->Advanced->Server supports folders that contain sub-folders and
messages. This option should be disabled in the described case. In this
situation folders get deleted permanently without moving to trash. 

Comment 5

16 years ago
Is the problem still occurring? 
QA Contact: huang → meehansqa

Comment 6

15 years ago
Yes, I have Mozilla 1.2.1 using UW IMAP server - still seeing the "The current
command did not succeed.  The mail server responded: RENAME failed:  Can'tcreate
mailbox node /export/home/bob/Trash/:  File exists"  Error message.

Users don't much like leaving the "remove immediately" setting in place because
they are always afraid of deleting the wrong thing and miss the safety of the
trashcan.

Seeing this on linux,windows, and Mac
Product: MailNews → Core

Comment 7

11 years ago
dupes?
Assignee: mscott → nobody
QA Contact: meehansqa → backend
Summary: Deleting folders on IMAP → Deleting folders on IMAP does not work with some IMAP servers

Comment 8

10 years ago
Robert, do you still see problem?   (reporter's address is dead)
Whiteboard: CLOSEME 2008-05-17 dupeme

Comment 9

10 years ago
Robert doesn't see problem anymore.
=> WFM
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.