Does not save as the viewing charset in composer

VERIFIED DUPLICATE of bug 69911

Status

()

Core
Internationalization
P2
normal
VERIFIED DUPLICATE of bug 69911
18 years ago
17 years ago

People

(Reporter: Teruko Kobayashi, Assigned: kill this account)

Tracking

({intl})

Trunk
Future
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
When you have the wrong meta-charset info page then you want to correct it by 
using composer, Netscape does not change meta-charset when you use Save as 
menu.

Steps of reproduce
1. Go to above URL
2. Select File|EditPage to open Composer (at this time, you see garbage 
characters)
3. Select menu View|Character coding->More->East Asian->Japanese(Shift_JIS)
   Now, Japanese characters are displayed correctly.
4. Select menu File|Save as.. to save to it local drive

In the saved html, the meta-charset is not changed to Shift_JIS.
It remains ISO-8859-1.

Tested 2000-10-11-08 MN6 build.
(Reporter)

Updated

18 years ago
Keywords: rtm

Comment 1

18 years ago
Teruko/Ftang - Is this something you thing we could release note, or is it an
absolute MUST FIX in your mind? (i.e. It is currently marked as P3, hence I
would vote to release note and ship).

Please Advise . . .
(Reporter)

Comment 2

18 years ago
Users will be confused this behavior.  We should fix.
Priority: P3 → P2

Comment 3

18 years ago
Thanks for your comments Teruko, but I think we may have run out of time on this 
one.

Ftang - What do you think are chances of getting this fixed are, right now?
(Reporter)

Comment 4

18 years ago
After I talked with Frank and Brian, this is not critical.  This does not destroy anything.
We may need to leave as it is now for RTM since we do not have time. 

Comment 5

18 years ago
Thanks for the input Teruko. Let's minus this one.

Comment 6

18 years ago
rtm-, agreeing and marking.
Whiteboard: [rtm-]
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 7

17 years ago
Added nsbeta1 and intl keywords.
Keywords: intl, nsbeta1
(Assignee)

Comment 8

17 years ago
added momoi-san 

Comment 9

17 years ago
Please file another important bug related to this.
The test page has an incorrect charset tag. When you
go there with Browser, the page is displayed incorrectly.
The normal thing for the user is then to correct the
display first to Shift_JIS. Then the user will
open it.
At present, it will open to incorrect display.
The spec is that the Composer page needs to reflect
the new charset when the user overrides the original
one. These 2 are probably related but this other
problem is what the user will do most likely. 
(Reporter)

Comment 10

17 years ago
Changed QA contact to ylong@netscape.com.
QA Contact: teruko → ylong
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Comment 11

17 years ago
Cleaning Staus Whiteboard and keyword. 

BStell/Ftang - Can we fix this one for nsbeta1?
Keywords: rtm
Whiteboard: [rtm-]

Comment 12

17 years ago
Change QA contact to Marina, and there is another related bug 77229.
QA Contact: ylong → marina

Comment 13

17 years ago
re-assigning QA contact
QA Contact: marina → ylong

Comment 14

17 years ago
Minusing this one, since no one has been all that interested in it, of late.
Keywords: nsbeta1 → nsbeta1-
bstell: I'm volunteering to take this off your plate. I'm working on a similar 
fix for bug 69911 and could easily accommodate this issue. If you agree, just 
reassign this to me...
teruko, please contact me, if you can't verify this.

*** This bug has been marked as a duplicate of 69911 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 17

17 years ago
Mark it as verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.