Form History sync takes a very long time and slows the browser down

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: felix.saparelli, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100407 Ubuntu/9.10 (karmic) Ant.com Toolbar 2.0.1 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100407 Ubuntu/9.10 (karmic) Ant.com Toolbar 2.0.1 Firefox/3.6.3

When Weave is syncing Form History, the browser slows down to a point when it is inefficient to do anything -- for example, searching google from the search bar takes about a minute instead of the usual 1 second. The sync also takes a very long time: around 5 minutes.

It is very frustrating, and has led me to disconnect Weave when I browse, and once in a while leave it to sync when I do nothing.

Reproducible: Always

Steps to Reproduce:
1. Install Weave on Firefox on Ubuntu 9.10
2. Open Firefox
3. Wait until Weave syncs.
Actual Results:  
Browser slows down to speed which do not enable any work to be done efficiently, taking very long to complete the sync. When sync is complete, the browser's state and speed returns to normal.

Expected Results:  
Browsing speed should not be affected, or only minorly, and sync should complete in a matter of a dozen seconds, as it does on other boxes I've got.

It is possible that this bug isn't related to Weave itself, but rather to my computer setup:

HP Mini 1001TU
1.60 GHz Intel Atom
1 GB DDR2 RAM
No HDD, system is running on 8 GB microSD in the integrated card slot.

Ubuntu 9.10 (karmic)
Gnome 2

The slow sync speed I experience could be linked to the write speed of the microSD, although the system is overall very fine with other disk-intensive applications running.
(Reporter)

Updated

9 years ago
Whiteboard: form history
can you still reproduce in either 1.2.3 or 1.3b4?  We were syncing all of form history, which really didn't perform as well as we'd hope, but that's not true now.
Component: Sync → Needs Triage
QA Contact: sync → needstriage
Whiteboard: form history
(Reporter)

Comment 2

9 years ago
Updating to 1.2.3 fixes it, thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
also verified with 1.3b5
Status: RESOLVED → VERIFIED
Component: Needs Triage → General
QA Contact: needstriage → general
You need to log in before you can comment on or make changes to this bug.