Closed Bug 562087 Opened 11 years ago Closed 11 years ago

Update pixman to newer version

Categories

(Core :: Graphics, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

Details

Attachments

(1 file)

Here's what changed:


Alan Coopersmith (3):
      Update Sun license notices to current X.Org standard form
      Make .s target asm flag selection more portable
      Add Sun cc to thread-local support checks in pixman-compiler.h

Alexander Larsson (11):
      Add extern "C" guards for c++
      Add pixman_image_get_destroy_data()
      Move SCREEN_SHIFT_LEFT/RIGHT to pixman-private.h
      Add pixman_region{32}_init_from_image
      Test pixman_region32_init_from_image in region-test
      Add CONVERT_0565_TO_8888 macro
      Add CONVERT_8888_TO_8888 and CONVERT_0565_TO_0565 macros
      Add FAST_PATH_NO_NONE_REPEAT flag
      Add FAST_PATH_SAMPLES_COVER_CLIP and FAST_PATH_16BIT_SAFE
      Add specialized fast nearest scalers
      Use the right format for the OVER_8888_565 fast path

Benjamin Otte (5):
      Fix typo
      Make region argument to pixman_region(32)_init_rects() const
      Add pixman_image_composite32()
      Add pixman_image_fill_boxes() API
      Make pixman_image_fill_rectangles() call pixman_image_fill_boxes()

Egor Starkov (1):
      Eliminate trailing comma in enum

Jon TURNEY (1):
      Avoid a potential division-by-zero exeception in window-test

Loïc Minier (1):
      ARM: SIMD: Try without any CFLAGS before forcing -mcpu=

Makoto Kato (1):
      Compile by USE_SSE2 only without USE_MMX

Matthias Hopf (2):
      Improve PIXREGION_NIL to return true on degenerated regions.
      Revert "Improve PIXREGION_NIL to return true on degenerated regions."

Siarhei Siamashka (9):
      ARM: Remove any use of environment variables for cpu features detection
      ARM: added 'neon_composite_over_n_8888_8888_ca' fast path
      ARM: added 'neon_composite_src_x888_8888' fast path
      ARM: added 'neon_composite_over_reverse_n_8888' fast path
      ARM: Use '.object_arch' directive in NEON assembly file
      ARM: Workaround for a NEON bug in assembler from binutils 2.18
      ARM: Helper ARM NEON assembly binding macros moved into a separate header
      ARM: SIMD optimizations updated to use common assembly calling conventions
      ARM: SIMD optimizations moved to a separate .S file

Siddharth Agarwal (1):
      Visual Studio 2010 includes stdint.h

S√∏ren Sandmann Pedersen (97):
      Fix slightly skewed sampling grid for antialiased traps
      Fix rounding of top and bottom coordinates.
      Round horizontal sampling points towards northwest.
      fetch-test: Various formatting fixes
      fetch-test: Fix spelling error (pallete -> palette)
      test: Add new alphamap test program.
      When fetching from an alpha map, use the alpha map's fetch function.
      pixman_image_validate() needs to also validate the alpha map.
      When fetching from an alpha map, replace the alpha channel of the image
      bits: Print an error if someone tries to create an image with bpp < depth
      Pre-release version bump
      Post-release version bump
      Fix some warnings
      Implement get_scanline_64() correctly for solid fill images.
      Turn some uint16_t variables to int32_t in the fast paths.
      Move the sanity checks for src, mask and destination into get_fast_path()
      Move pixbuf checks after src_format and mask_format have been computed.
      Consolidate the source and mask sanity checks in a function
      Fold get_fast_path() into _pixman_run_fast_path()
      Move calls to source_is_fastpathable() into get_source_format()
      Add src_, mask_, and dest_flags fields to fast path arrays
      Compute src, mask, dest flags and base fast path decisions on them.
      Move checks for src/mask repeat right before walking the region.
      Turn off asserts in development snapshots (bug 26314).
      Makefile.am: Remove 'check' from release-check
      Merge branch 'bitmasks'
      Generalize and optimize fast_composite_src_scaled_nearest()
      Once unrolled version of fast_path_composite_nearest_scaled()
      Pre-release version bump
      Post-release version bump
      Make general_composite_rect() just another fast path.
      Make fast_composite_scaled_nearest() another fast path.
      Store a pointer to the array of fast paths in the implementation struct.
      Delete unused sources_cover() function
      Don't call _pixman_implementation_composite() anymore.
      Delete unused _pixman_walk_composite_region() function
      Eliminate all the composite methods.
      Optimize for the common case wrt. the workaround.
      Move compositing to its own function, do_composite()
      Move compositing functionality from pixman-utils.c into pixman.c
      Manually inline _pixman_run_fast_path()
      Move get_image_info() out of the loop in do_composite
      Move region computation out of the loop in do_composite()
      Move more things out of the inner loop in do_composite().
      Add a fast path for non-repeating sources in walk_region_internal().
      Move NULL check out of get_image_info()
      Move all code to do debugging spew into pixman-private.
      Merge branch 'eliminate-composite'
      Hide the C++ extern "C" declarations behind macros.
      Add a1-trap-test
      Merge branch 'trap-fixes'
      Pre-release version bump
      Post-release version bump
      RELEASING: Update the release instructions.
      Compute the image flags at validation time instead of composite time
      Add new FAST_PATH_SIMPLE_REPEAT flag
      Move computation of extended format code to validate.
      Eliminate _pixman_image_is_solid()
      Eliminate _pixman_image_is_opaque() in favor of a new FAST_PATH_IS_OPAQUE flag
      Turn need_workaround into another flag.
      Move workaround code to pixman-image.c
      Restructure the flags computation in compute_image_info().
      test: Remove obsolete comment
      Merge branch 'more-flags'
      Move __force_align_arg_pointer workaround before composite32()
      Pre-release version bump to 0.17.10
      Post-release version bump to 0.17.11
      Add a fast path cache
      Make the operator strength reduction constant time.
      Store the operator table more compactly.
      Strength reduce certain conjoint/disjoint to their normal counterparts.
      Change operator table to be an array of arrays of four bytes.
      Merge branch 'fast-path-cache'
      Merge branch 'operator-table'
      pixman.h: Only define stdint types when PIXMAN_DONT_DEFINE_STDINT is undefined
      test: Add support for indexed formats to blitters-test
      Fix typo: WORDS_BIG_ENDIAN => WORDS_BIGENDIAN in pixman-edge.c
      Add checks for various types of thread local storage.
      Add PIXMAN_DEFINE_THREAD_LOCAL() and PIXMAN_GET_THREAD_LOCAL() macros
      Fix contact address in configure.ac
      Ensure that only the low 4 bit of 4 bit pixels are stored.
      Add a FAST_PATH_X_UNIT_POSITIVE flag
      Specialize the fast_composite_scaled_nearest_* scalers to positive x units
      Pre-release version bump to 0.17.12
      Post-release version bump to 0.17.13
      Merge remote branch 'ssvb/arm-fixes'
      Pre-release version bump to 0.17.14
      Post-release version bump to 0.17.15
      Pre-release version bump to 0.18.0
      Post-release version bump to 0.19.1
      Fix uninitialized cache when pthreads are used
      Fixes for pthread thread local storage.
      [mmx] Fix mask creation bugs
      Update README to mention the pixman mailing list
      Some minor updates to README
      Add pixman_image_get_format() accessor
      Remove alphamap from the GTK+ part of tests/Makefile.am
Duplicate of this bug: 552142
Is ARM msvc support still needed? If not I'd like to avoid the work of updating it.
Attached patch update pixmanSplinter Review
Jeff, no its not required.  Please add a note to the README though in case we ever decide to revive it.
Blocks: 563488
Blocks: 540999
http://hg.mozilla.org/mozilla-central/rev/9b1cbf1ba5cd
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
jeff, i think that changeset was for bug 563807 and the corespondent changeset for this bug is:

http://hg.mozilla.org/mozilla-central/rev/ea50a508efb5
Indeed.
Assignee: nobody → jmuizelaar
Depends on: 773597
You need to log in before you can comment on or make changes to this bug.