Crash - R6016 - not enough space for thread data

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Jim Schrempp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

I cannot reproduce this. It has happened once, although the error dialog showed up again when I clicked OK to the first error dialog box. This is a standard C++ Runtime error dialog. It indicates firefox.exe and R6016 - not enough space for thread data.

I had about 10 tabs open at the time. I was not interacting with FF at the time, it was in the background.

This pop up dialog appeared. I dismissed the dialog by clicking OK and it came up again. I clicked OK on that dialog and FF went away.

I restarted FF. It said it could not restore my session. I asked it to try anyway. The session did restart with all the tabs. When it restarted Google RSS reader was the active visible tab.

Hope this helps.

Reproducible: Couldn't Reproduce

Comment 1

8 years ago
https://developer.mozilla.org/En/How_to_get_a_stacktrace_with_windbg

when you get that dialog, you need to attach windbg to the running firefox and use the ~* kp/!analyze instructions.

It's possible this is from a plugin or related third party module.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Comment 3

8 years ago
Never saw it again, so sure, I'll close.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 4

5 years ago
I know this is very old and im on a Nightly but i was getting this same error everytime i close firefox 26.0a1. It was due to Tab Mix Lite 4.21. Removed addon and problem error went away.
You need to log in before you can comment on or make changes to this bug.