hang when clicking any textinput box with xcin running

VERIFIED INVALID

Status

()

Core
Internationalization
P3
critical
VERIFIED INVALID
17 years ago
16 years ago

People

(Reporter: Brian Coons, Assigned: nhottanscp)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (X11; U; Linux 2.2.14 i586)
BuildID:    2000100613

Mozilla hangs when I click in different textboxes during message composition in
mail/news while running xcin 2.5.1-4

Reproducible: Always
Steps to Reproduce:
1.run xcin (LANG=zh) (LC_ALL=zh_cn)
2.run mozilla -mail
3.click new message
4.click in the To: textbox (where email address goes) or the message textbox or
hit return

or
1. run mozilla -mail (LANG=zh, LC_ALL=zh_CN)
2. click new message
3. click on message textbox
4. run xcin 2.5.1-4
5. enter chinese or english characters
6. click on To: textbox (the box where email address goes)

Actual Results:  I got this message from xcin and mozilla hung.
xcin: warning: ic_get: unknown IC pre_attr: (null)

                           

Expected Results:  Mozilla should not hang.

Netscape 4.61 [en], gnomeICU, and rxvt work fine with this
xcin.
(Assignee)

Comment 1

17 years ago
Xianglan, do you have the environment to try this?

Comment 2

17 years ago
Unfortunately I don't have the environment to try this.
Brian, what linux system did you use to reproduce the problem?
(Reporter)

Comment 3

17 years ago
Redhat 6.0 I think.  (Or was it 6.1, I'm not at home right now.)

The only additional environment needed is to setup the zh_CN locale and install
xcin, there are RPM's available.  Then set the variables LANG=zh LC_ALL=zh_CN

Comment 4

17 years ago
Brian, do you know where I get those rpms for xcin?
Thanks.

Comment 5

17 years ago
Did you see this hanging problem when you click in the HTML Composer or url location bar on the browser?
(Reporter)

Comment 6

17 years ago
There are xcin rpms available here but I couldn't find the same version as an
rpm.  Maybe I installed it from source.
http://rpmfind.net/linux/rpm2html/search.php?query=xcin

Here you can find the close to the same version I used to create the error, but
you might be able to recreate it with other versions.
ftp://xcin.linux.org.tw/pub/xcin/xcin/xcin-2.5.1-5.tar.gz
This might be a dependency:
ftp://xcin.linux.org.tw/pub/xcin/libtabe/libtabe-0.1-pre5.tar.gz

Xcin Homepage
http://xcin.linux.org.tw/

Here is the exact same version I used, but it is from a FreeBSD site, should
work though, it's source:
http://bsd.sinica.edu.tw/ftp_pub/FreeBSD/taiwan/xcin/xcin/xcin-2.5.1-4.tar.gz
(Reporter)

Comment 7

17 years ago
>Did you see this hanging problem when you click in the HTML Composer or url
location bar on the browser?

I only tried it with mail, I'll try it with the browser and HTML composer
tonight.
(Reporter)

Comment 8

17 years ago
yes, this also occurs when I click in the browser URL location box,
the composer textbox, or in addressbook in a new card textbox.

[mozilla-oct7]$ uname -a
Linux localhost 2.2.14 #3 Sun Jan 23 21:45:30 CST 2000 i586 unknown
[mozilla-oct7]$ cat /etc/redhat-release 
Red Hat Linux release 6.0 (Hedwig)
(Reporter)

Comment 9

17 years ago
updated the summary.  The scope is beyond Mail/news, but I can't select mutliple
products.  M18 is out today, good work.
Summary: hang when running xcin and composing message → hang when clicking any textinput box with xcin running

Comment 10

17 years ago
Chaanged the Product to Browser and added teruko to cc list.
Product: MailNews → Browser

Comment 11

17 years ago
Here is the message from the XCIN owner-
From: 
        thhsieh@linux.org.tw
                                                                         Fri 
17:34

 Subject: 
        Re: Frank Tang
     To: 
        ftang@netscape.com




: CyberMax.bbs@openbazarar.net have report this on the  tlug.xcin
: newsgroup
: Message ID  <3bKkk7$0in@openbazaar.net> . However, that message is in
: Chinese. He said
: If I run xcin first, then I cannot run Mozilla M16 (it will stop after
: it run run-mozilla.sh). xcin will display the following warning
: 
: xcin: warning: ic_get: unknown IC pre_attr: (null)
: 
:     any suggestion?
: 
: It seems the same problem as bug 56220

Hello,

This bug is already solved in xcin side. Please try:

ftp://xcin.linux.org.tw/pub/xcin/xcin/devel/xcin-2.5.2.pre6.tar.gz
ftp://xcin.linux.org.tw/pub/xcin/xcin/patch/xcin-2.5.2.pre6.diff1.gz

Please add the xcin-2.5.2.pre6.diff1.gz patch first before compiling
xcin system.

By the way, the stable version of xcin-2.5.2 will be released in one
or two days. You can also wait for the stable release and test it.


Regards,

T.H.Hsieh

Mark this bug as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 12

17 years ago
Per T.H.Hsieh's comments as quoted in ** Additional Comments
From Frank Tang 2000-10-16 15:11 **, the problem needed to be
solved on the XCIN side.
Marking the bug invalid as a newer version of XCI is
available for the problem.
Status: RESOLVED → VERIFIED

Comment 13

16 years ago
Hello,

I am using the new development of xcin with mozilla-0.9.5, and almost
everything seems good. The xcin bug mentioned here should be fixed.
The interesting people are encouraged to try the new development of
xcin:

         http://xcin.linux.org.tw/download.html#cvs

Note that the newest development always appears in the xcin cvs. If
you want to try it, please download both the libtabe package and xcin
package and install them.

Besides, mozilla-0.9.5 still has little problem. For reference, please
see:

         http://bugzilla.mozilla.org/show_bug.cgi?id=109723

T.H.Hsieh         
You need to log in before you can comment on or make changes to this bug.