User interface - history window is refreshed each time a page is loaded

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Chris, Unassigned)

Tracking

3.6 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100402 Namoroka/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100402 Namoroka/3.6.3

Every time a page is loaded, the history window is refreshed, the view is going back to "Today".
It's annoying because History is used to find a link, but each time a link is opened to check if this is the link we are looking for, we are loosing the current history view, and we are unable to test immediatly the next link in the list without going back to the previous view (and potentially to set up back the sort order).

This bug does not exist if we write something in the search field... but it's useless if we know only a date interval.

Reproducible: Always

Steps to Reproduce:
1. click History, Show all history (it opens the History window)
2. select "Yesterday" (for example)
3. double click on a link (an history item)
Actual Results:  
after the page is loaded, the history windows is refreshed, you are no more in "Yesterday" but back in "Today"

Expected Results:  
after the page is loaded, the history windows should not be refreshed, the link clicked must be removed (because it is now in "Today"), but the view must stay in Yesterday (the current item)

Arch linux - KDE - Namoroka
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Updated

8 years ago
OS: Linux → All
(Reporter)

Updated

8 years ago
Component: General → Bookmarks & History
QA Contact: general → bookmarks
(Reporter)

Comment 1

8 years ago
It looks like a regression bug, because it works fine on Firefox/3.5.9

Tested on:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9

It's like expected results: after the page is loaded, the history window is not refreshed, and the link is not removed (but maybe also present in "Today", I haven't checked). It's even better because the link is not removed and we can easily know what is the next link to try.
I think we don't do this anymore
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.