If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Form helper interferes with litmus.mozilla.org

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: vingtetun)

Tracking

({testcase})

Fennec 1.1
x86
Windows 7
testcase

Details

(Whiteboard: formfill, URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 441978 [details]
testcase

I tried to run tests from litmus.mozilla.org on the Nokia n900, but I already got stuck, while trying to give the OS that I use.

Anyway, to reproduce the issue, see testcase:
- Click on the first multiple select
- In the form helper, mark one or both of the options as selected
- Click on the "Next" button in the form helper

Expected result:
The next multiple select is focused, the form fill helper ui is updated with the option 'a' and 'b' to choose from.

Actual result:
The next multiple select is focused, but the form fill helper ui is only showing the first option 'a', not the second option 'b'.

This is probably happening, because the setCurrentElement function is first updating the form fill helper ui and then focusing the next form element:
http://mxr.mozilla.org/mobile-browser/source/chrome/content/browser-ui.js#1584
But in this case, that is not working. It seems to me, first the next form element should get focused, then the form fill helper ui should get updated (populating it with the then available options).
Whiteboard: formfill
Whiteboard: formfill → formfill mobile-triage
Assignee: nobody → 21
Whiteboard: formfill mobile-triage → formfill
(Reporter)

Comment 1

5 years ago
Mass resolving XUL Fennec I filed to WORKSFORME. If someone still cares about this bug, please reopen.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.