[H4BTN]<hr> in <button> looks bad, causes button to grow on hover/click

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: jruderman, Assigned: rods)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Hover or click any of the buttons in the testcase that contain <hr>.  The 
button will grow vertically, pushing down any text below the <hr>.  An 
exception is the button just containing the <hr>, which ends up looking like it 
contains three <hr>s but stops growing at that point.

Also note that the <hr>s inside buttons look bad in general.  HTML 4 allows 
pretty much anything in buttons besides other forms elements, and IE displays 
them nicely.
(Reporter)

Comment 1

18 years ago
Created attachment 16855 [details]
testcase
(Assignee)

Comment 2

18 years ago
wow, that is bad, don't do that :)

I'll have to take a look. futuring for now.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 3

18 years ago
See also bug 26644.
(Assignee)

Updated

18 years ago
Summary: <hr> in <button> looks bad, causes button to grow on hover/click → [H4BTN]<hr> in <button> looks bad, causes button to grow on hover/click
(Reporter)

Comment 4

18 years ago
*** Bug 69959 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
QA Contact Update
QA Contact: bsharma → vladimire

Comment 6

17 years ago
Note:

When the document has a invalid doctype 
(<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 //EN">)  [validator on w3c.org
sais.. that's not a good doctype :)]

, the buttons _won't_ grow or shrink!

See:
http://www.8ung.at/efu/butest.html

And:
http://www.8ung.at/efu/butestx.html
for more details..

butest.html is a document with the 'invalid' doctype -> works fine
butestx.html is a document with a VALID doctype -> doesn't work fine

... a html page without a doctype also won't work...
(Assignee)

Updated

17 years ago
Priority: P3 → --
Testcase seems to be fine in W2K 2003011508.  No growing buttons (I did see this
ages ago).  FIXED?

Comment 8

16 years ago
Works for me on build 2003-01-09-08-trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
verifying build 2003-02-12-08-trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.