Content not appearing correctly on Usmagazine.com

VERIFIED FIXED

Status

()

Core
Layout
P1
normal
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: chelsea, Assigned: jrmuizel)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 beta1+)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

8 years ago
str:
1)Go to usmagazine.com
2)notice missing content to right on main photo
3)hover over area with mouse notice links appear - same with photo on far right
4)scroll up and down, notice content disappears again

tested with 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100427 Minefield/3.7a5pre
(Reporter)

Comment 1

8 years ago
Created attachment 442082 [details]
not right
(Reporter)

Comment 2

8 years ago
Created attachment 442083 [details]
right
Works in Firefox 3.6.3, so looks like a recent trunk regression. Layers?
Hmm.  I don't see the problem, with the same exact build and OS as in comment 0.  Either in my usual browsing profile, or a clean profile.
I don't see it exactly as reported, but I do see problems.
Assignee: nobody → roc
blocking2.0: --- → ?
(Assignee)

Comment 6

8 years ago
I believe this is problem from the cairo update. We screw up the clipping when drawing the object frame.
(Assignee)

Comment 7

8 years ago
Created attachment 442233 [details]
A simplified test case
Assignee: roc → jmuizelaar
We didn't take that Cairo update on any of the branches, did we?
(Assignee)

Comment 9

8 years ago
Nope
(Assignee)

Comment 10

8 years ago
Created attachment 442414 [details] [diff] [review]
Fix cairo_quartz_get_cg_context_with_clip

This problem happens when clip->all_clipped is set and we go to get a clipped context. Normally backends don't see operations with clip->all_clipped and so _cairo_surface_clipper_set_clip is designed with the assumption that clip->all_clipped is never true. I added a work-around by manually setting the CGContextClip with an empty rectangle, however this caused cairo to be confused about what the actual clip was.

This patch fixes the problem by adding a new function cairo_quartz_finish_cg_context_with_clip that is called after we're done with the native context. It moves the CGContextSave/RestoreGState calls out of gfxNativeDrawing into cairo and uses them to ensure that the clip remains consistent with cairo's model of them.
Attachment #442414 - Flags: review?(vladimir)
(Assignee)

Comment 11

8 years ago
I checked in a broken version of this last night.
It should be correct now:
http://hg.mozilla.org/mozilla-central/rev/31d4639e6857
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Duplicate of this bug: 562651

Comment 13

8 years ago
The simplified test case still renders incorrectly in the current nightly (1e383909069b), zooming in and out causes different parts to render.
Verified FIXED for me, using:

Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100506 Minefield/3.7a5pre
Status: RESOLVED → VERIFIED
blocking2.0: ? → beta1+
Priority: -- → P1
You need to log in before you can comment on or make changes to this bug.