crash in gfx Running e10s Fennec under Ubuntu

VERIFIED DUPLICATE of bug 552015

Status

Fennec Graveyard
General
--
major
VERIFIED DUPLICATE of bug 552015
8 years ago
7 years ago

People

(Reporter: Brian Crowder, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
#0  pixman_blt_mmx (src_bits=<value optimized out>, dst_bits=<value optimized out>, src_stride=512, dst_stride=798, src_bpp=32, dst_bpp=32, src_x=0, src_y=0, dst_x=0, dst_y=3, width=512, height=427) at /home/crowder/me10s/gfx/cairo/libpixman/src/pixman-mmx.c:3056
#1  0x00debb9a in walk_region_internal (imp=<value optimized out>, op=<value optimized out>, src_image=0x846a798, mask_image=0x0, dst_image=0x88a43b8, src_x=0, src_y=0, mask_x=0, mask_y=0, dest_x=0, dest_y=3, width=512, height=428, src_repeat=0, mask_repeat=0, region=0xbfffb46c, composite_rect=0xdecff0 <mmx_composite_copy_area>) at /home/crowder/me10s/gfx/cairo/libpixman/src/pixman-utils.c:444
#2  0x00dec8c5 in _pixman_run_fast_path (paths=0xfbfea0, imp=0xb484d720, op=PIXMAN_OP_SRC, src=0x846a798, mask=0x0, dest=0x88a43b8, src_x=0, src_y=0, mask_x=0, mask_y=0, dest_x=0, dest_y=3, width=512, height=428) at /home/crowder/me10s/gfx/cairo/libpixman/src/pixman-utils.c:749
#3  0x00ded43f in mmx_composite (imp=0xb484d720, op=PIXMAN_OP_SRC, src=0x846a798, mask=0x0, dest=0x88a43b8, src_x=0, src_y=0, mask_x=0, mask_y=0, dest_x=0, dest_y=3, width=512, height=428) at /home/crowder/me10s/gfx/cairo/libpixman/src/pixman-mmx.c:3304
#4  0x00de4d63 in _pixman_implementation_composite (imp=0xb484d720, op=PIXMAN_OP_SRC, src=0x846a798, mask=0x0, dest=0x88a43b8, src_x=0, src_y=0, mask_x=0, mask_y=0, dest_x=0, dest_y=3, width=512, height=428) at /home/crowder/me10s/gfx/cairo/libpixman/src/pixman-implementation.c:229
#5  0x00de00af in _moz_pixman_image_composite (op=PIXMAN_OP_SRC, src=0x846a798, mask=0x0, dest=0x88a43b8, src_x=<value optimized out>, src_y=<value optimized out>, mask_x=<value optimized out>, mask_y=<value optimized out>, dest_x=<value optimized out>, dest_y=<value optimized out>, width=<value optimized out>, height=<value optimized out>) at /home/crowder/me10s/gfx/cairo/libpixman/src/pixman.c:204
#6  0x00d9e4ae in _cairo_image_surface_composite (op=CAIRO_OPERATOR_SOURCE, src_pattern=0xbfffc398, mask_pattern=0x0, abstract_dst=0x88a4478, src_x=0, src_y=3, mask_x=0, mask_y=0, dst_x=<value optimized out>, dst_y=<value optimized out>, width=<value optimized out>, height=<value optimized out>, clip_region=0x0) at /home/crowder/me10s/gfx/cairo/cairo/src/cairo-image-surface.c:1166
#7  0x00db5c6b in _cairo_surface_composite (op=CAIRO_OPERATOR_SOURCE, src=0xbfffc398, mask=0x0, dst=0x88a4478, src_x=0, src_y=3, mask_x=0, mask_y=0, dst_x=0, dst_y=3, width=512, height=428, clip_region=0x0) at /home/crowder/me10s/gfx/cairo/cairo/src/cairo-surface.c:1821
#8  0x00db9e0d in _composite_rectangle (src=<value optimized out>, op=CAIRO_OPERATOR_SOURCE, dst=0x88a4478, traps=0xbfffbe0c, antialias=CAIRO_ANTIALIAS_DEFAULT, clip=0x0, extents=0xbfffc2b8) at /home/crowder/me10s/gfx/cairo/cairo/src/cairo-surface-fallback.c:740
#9  _clip_and_composite_trapezoids (src=<value optimized out>, op=CAIRO_OPERATOR_SOURCE, dst=0x88a4478, traps=0xbfffbe0c, antialias=CAIRO_ANTIALIAS_DEFAULT, clip=0x0, extents=0xbfffc2b8) at /home/crowder/me10s/gfx/cairo/cairo/src/cairo-surface-fallback.c:789
#10 0x00dba862 in _cairo_surface_fallback_fill (surface=0x88a4478, op=CAIRO_OPERATOR_SOURCE, source=0xbfffc398, path=0x10cc914, fill_rule=CAIRO_FILL_RULE_WINDING, tolerance=0.10000000000000001, antialias=CAIRO_ANTIALIAS_DEFAULT, clip=0x0) at /home/crowder/me10s/gfx/cairo/cairo/src/cairo-surface-fallback.c:1406
#11 0x00db683e in _cairo_surface_fill (surface=0x88a4478, op=CAIRO_OPERATOR_SOURCE, source=0xbfffc398, path=0x10cc914, fill_rule=CAIRO_FILL_RULE_WINDING, tolerance=0.10000000000000001, antialias=CAIRO_ANTIALIAS_DEFAULT, clip=0xbfffc478) at /home/crowder/me10s/gfx/cairo/cairo/src/cairo-surface.c:2222
#12 0x00d9b185 in _cairo_gstate_fill (gstate=0x88a4688, path=0x10cc914) at /home/crowder/me10s/gfx/cairo/cairo/src/cairo-gstate.c:1177
#13 0x00d93096 in *INT__moz_cairo_fill_preserve (cr=0x10cc688) at /home/crowder/me10s/gfx/cairo/cairo/src/cairo.c:2338
#14 0x006edf4d in nsCanvasRenderingContext2D::Render (this=0x871b1e0, ctx=0x88a3fa0, aFilter=143277984) at /home/crowder/me10s/content/canvas/src/nsCanvasRenderingContext2D.cpp:1199
#15 0x0072d2d3 in nsHTMLCanvasElement::RenderContexts (this=0x8744008, ctx=0x88a3fa0, aFilter=gfxPattern::FILTER_GOOD) at /home/crowder/me10s/content/html/content/src/nsHTMLCanvasElement.cpp:528
#16 0x005847f0 in nsHTMLCanvasFrame::PaintCanvas (this=0x87793b8, aRenderingContext=..., aDirtyRect=..., aPt=...) at /home/crowder/me10s/layout/generic/nsHTMLCanvasFrame.cpp:255
#17 0x00584c4b in nsDisplayItemCanvas::Paint (this=0x876e31c, aBuilder=0xbfffc940, aCtx=0x88a4648) at /home/crowder/me10s/layout/generic/nsHTMLCanvasFrame.cpp:73
#18 0x00531715 in nsDisplayList::PaintThebesLayers (this=0xbfffc92c, aBuilder=0xbfffc92c, aLayers=...) at /home/crowder/me10s/layout/base/nsDisplayList.cpp:850
#19 0x00533bbd in nsDisplayList::Paint (this=0xbfffc92c, aBuilder=0xbfffc940, aCtx=0x0, aFlags=<value optimized out>) at /home/crowder/me10s/layout/base/nsDisplayList.cpp:778
#20 0x00543437 in nsLayoutUtils::PaintFrame (aRenderingContext=0x0, aFrame=0x85bd3d0, aDirtyRegion=..., aBackstop=4292206054, aFlags=<value optimized out>) at /home/crowder/me10s/layout/base/nsLayoutUtils.cpp:1257
#21 0x0055513f in PresShell::Paint (this=0x85bae88, aDisplayRoot=0x8315718, aViewToPaint=0x8315718, aWidgetToPaint=0x8315770, aDirtyRegion=..., aPaintDefaultBackground=0) at /home/crowder/me10s/layout/base/nsPresShell.cpp:5629
#22 0x007e6083 in nsViewManager::RenderViews (this=0x83156c8, aView=0x8315718, aWidget=0x8315770, aRegion=...) at /home/crowder/me10s/view/src/nsViewManager.cpp:453
#23 0x007e7f2e in nsViewManager::Refresh (this=0x83156c8, aView=0x8315718, aWidget=0x8315770, aRegion=..., aUpdateFlags=1) at /home/crowder/me10s/view/src/nsViewManager.cpp:426
#24 0x007e8211 in nsViewManager::DispatchEvent (this=0x83156c8, aEvent=0xbfffcf94, aView=0x8315718, aStatus=0xbfffcecc) at /home/crowder/me10s/view/src/nsViewManager.cpp:877
#25 0x007e5071 in HandleEvent (aEvent=0xbfffcf94) at /home/crowder/me10s/view/src/nsView.cpp:160
#26 0x00b97244 in nsWindow::DispatchEvent (this=0x8315770, aEvent=0xbfffcf94, aStatus=@0xbfffcf1c) at /home/crowder/me10s/widget/src/qt/nsWindow.cpp:2282
#27 0x00b9bdd5 in nsWindow::DispatchEvent (this=0x8315770, aEvent=0xbfffcf94) at /home/crowder/me10s/widget/src/qt/nsWindow.h:210
#28 0x00b99e93 in nsWindow::DoPaint (this=0x8315770, aPainter=0x8315770, aOption=0x844bc9c) at /home/crowder/me10s/widget/src/qt/nsWindow.cpp:1064
#29 0x019b897a in ?? () from /usr/lib/libQtGui.so.4
#30 0x019c3de1 in ?? () from /usr/lib/libQtGui.so.4
#31 0x019c61f4 in QGraphicsScene::drawItems(QPainter*, int, QGraphicsItem**, QStyleOptionGraphicsItem const*, QWidget*) () from /usr/lib/libQtGui.so.4
#32 0x019d3ebc in QGraphicsView::drawItems(QPainter*, int, QGraphicsItem**, QStyleOptionGraphicsItem const*) () from /usr/lib/libQtGui.so.4
#33 0x019e0bde in QGraphicsView::paintEvent(QPaintEvent*) () from /usr/lib/libQtGui.so.4
#34 0x013e5dd4 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#35 0x01795633 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#36 0x01834494 in QAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#37 0x019de51f in QGraphicsView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#38 0x01836a95 in ?? () from /usr/lib/libQtGui.so.4
#39 0x01d4c83a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#40 0x01390f2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#41 0x013985ca in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#42 0x01d4d6cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#43 0x013ede25 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib/libQtGui.so.4
#44 0x0157c233 in ?? () from /usr/lib/libQtGui.so.4
#45 0x013df116 in QWidgetPrivate::syncBackingStore() () from /usr/lib/libQtGui.so.4
#46 0x013e6215 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#47 0x01795633 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#48 0x01834faa in QAbstractScrollArea::event(QEvent*) () from /usr/lib/libQtGui.so.4
#49 0x019de406 in QGraphicsView::event(QEvent*) () from /usr/lib/libQtGui.so.4
#50 0x00b96343 in MozQGraphicsView::event (this=0x844b5b0, aEvent=0x8768d40) at ../../../../widget/src/qt/mozqwidget.h:162
#51 0x01390f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#52 0x013985ca in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#53 0x01d4d6cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#54 0x01d4e2b2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#55 0x01d4e47d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#56 0x01d783ff in ?? () from /usr/lib/libQtCore.so.4
#57 0x02865e88 in g_main_dispatch (context=0x8057490) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#58 IA__g_main_context_dispatch (context=0x8057490) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#59 0x02869730 in g_main_context_iterate (context=0x8057490, block=<value optimized out>, dispatch=1, self=0x8054d50) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#60 0x02869863 in IA__g_main_context_iteration (context=0x8057490, may_block=0) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#61 0x01d7802c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#62 0x01431be5 in ?? () from /usr/lib/libQtGui.so.4
#63 0x00b964f3 in nsAppShell::ProcessNextNativeEvent (this=0x8311780, mayWait=0) at /home/crowder/me10s/widget/src/qt/nsAppShell.cpp:111
#64 0x00ba2404 in nsBaseAppShell::DoProcessNextNativeEvent (this=0x8311788, mayWait=0) at /home/crowder/me10s/widget/src/xpwidgets/nsBaseAppShell.cpp:155
#65 0x00ba2537 in nsBaseAppShell::OnProcessNextEvent (this=0x8311788, thr=0x816bb68, mayWait=0, recursionDepth=0) at /home/crowder/me10s/widget/src/xpwidgets/nsBaseAppShell.cpp:293
#66 0x00ce1436 in nsThread::ProcessNextEvent (this=0x816bb68, mayWait=0, result=0xbfffef0c) at /home/crowder/me10s/xpcom/threads/nsThread.cpp:508
#67 0x00cb0458 in NS_ProcessNextEvent_P (thread=0xb3721568, mayWait=0) at nsThreadUtils.cpp:250
#68 0x00c3e0e3 in mozilla::ipc::MessagePump::Run (this=0x8162b70, aDelegate=0x816b9c8) at /home/crowder/me10s/ipc/glue/MessagePump.cpp:118
#69 0x00d1cc70 in MessageLoop::RunInternal (this=0x816b9c8) at /home/crowder/me10s/ipc/chromium/src/base/message_loop.cc:216
#70 0x00d1cc8e in MessageLoop::RunHandler (this=0x816b9c8) at /home/crowder/me10s/ipc/chromium/src/base/message_loop.cc:199
#71 0x00d1ccfe in MessageLoop::Run (this=0x816b9c8) at /home/crowder/me10s/ipc/chromium/src/base/message_loop.cc:173
#72 0x00ba26d1 in nsBaseAppShell::Run (this=0x8311788) at /home/crowder/me10s/widget/src/xpwidgets/nsBaseAppShell.cpp:174
#73 0x00a89c1c in nsAppStartup::Run (this=0x8316870) at /home/crowder/me10s/toolkit/components/startup/src/nsAppStartup.cpp:182
#74 0x0037cc00 in XRE_main (argc=1, argv=0xbffff4c4, aAppData=0x804e5c8) at /home/crowder/me10s/toolkit/xre/nsAppRunner.cpp:3551
#75 0x08048b62 in main (argc=1, argv=0xbffff4c4) at /home/crowder/me10s/mobile/app/nsBrowserApp.cpp:146
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 552015

Updated

8 years ago
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
Hardware: x86 → ARM
You need to log in before you can comment on or make changes to this bug.