Weave should sync on Firefox exit

RESOLVED WONTFIX

Status

Cloud Services
Firefox Sync: Backend
--
enhancement
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Witold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.2.5pre) Gecko/20100428 Namoroka/3.6.5pre
Build Identifier: 1.3b2

Weave should ask whether to sync when closing Firefox. Alternatively, there could be an option to set weave to "sync on exit".
I have many machines and it happened to me that I close Fx and don't find newly added bookmarks on other devices, because weave didn't upload them on exit.
It is possible to work around this by manually syncing, but it is easy to forget it.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
I tried to use "sync now" option, but it doesn't seem to work.
(Reporter)

Updated

8 years ago
Severity: minor → major
Component: General → Sync
This was in early prototypes, and interfered with expected results for users (i.e. closing the app could be delayed for quite some time).

The workaround is to force a sync, but we're not going to add a pref for this.  If Sync Now is failing, please file a separate bug on that issue.
Severity: major → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

8 years ago
Other addons (i.e. Xmarks) ask the user whether he/she wants to sync while exiting if new bookmarks/passwords are found and offer an option to automate this. While should this be an issue on Weave?

Also, just because there isn't such an option here, I risk losing some new elements (bookmarks, passwords, etc) because:
1) weave doesn't sync new things on exit
2) it doesn't even ask if I'd like to do so
3) I can NEVER know how often weave really sync. I can find some replies I got on google group weave about when weave does sync. (more or less...about...etc) 

However, thanks for NOT CARING FOR USER DATA. THANKS REALLY.  I'll switch to someone who does care ! f...g weave !!

Comment 4

8 years ago
With 1.4, the ability to "Sync Now" from the status bar is gone.

Please reconsider an option:
  Sync on exit: (ask | no | yes)

Actually, syncing does not take very long for me, but even when it would, this is a necessity if you want to have everything synced.
Having to manually trigger the "Sync now" adds a significant percentage to the whole time required to sync on exit actually.

You may want to add a Test Pilot case for this to gather more feedback, but common sense is that such an option would make the most sense.
(In reply to comment #4)
> With 1.4, the ability to "Sync Now" from the status bar is gone.

FWIW, this ability remains in the menu bar -- Tools | Sync | Sync Now
Really, the problem is not "I want to sync on shutdown" but "I want to switch contexts and not worry about whether my data has been synced" for all cases where client A is offline (app closed, machine in sleep, loss of network).  This pref mitigates one, but the right fix is to get more aggressive about when we sync to the server.

The _right_ solution, IMO, is something that solves all of these problems, and works for all users, without anyone having to think about it.  That's the best option, and one that we're pursuing.

Witold, the default intervals for sync depend on your client mix and usage.  With multiple desktop clients, the frequency is one hour.  However, there is also a local tracker score for detecting changes and forcing early syncs when there are a number of pending changes.  Clearly these values need to be more aggressive, and my intent is to start tuning those more aggressively over the next few releases.  I'm sorry to hear you're leaving, but it is absolutely not an issue of "not caring about data"
You need to log in before you can comment on or make changes to this bug.