Closed Bug 56250 Opened 20 years ago Closed 20 years ago

Stop button doesn't stop JavaScript function

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 51139

People

(Reporter: h.b.furuseth, Assigned: joki)

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS 5.7 sun4u; en-US; m18) Gecko/20001006
BuildID:    2000100610

The Stop button doesn't stop JavaScript function
set up with setTimeout().

Reproducible: Always
Steps to Reproduce:
1. Visit the upcoming attachment.
2. Press STOP.


Actual Results:  The bugger keeps blinking red/blue.

Expected Results:  It should freeze.

The Stop button is "disabled", but that's not
the problem.  It does stop animated background
images (Debug/Viewer Demos/Test 2) even though
it's "disabled" there.
confirming with linux build 101109
event handling, os all, confirming
Assignee: asa → joki
Status: UNCONFIRMED → NEW
Component: Browser-General → Event Handling
Ever confirmed: true
OS: Solaris → All
QA Contact: doronr → lorca

*** This bug has been marked as a duplicate of 51139 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Changing summary.

VERIFIED.  Changing Plat/OS to ALL.
Status: RESOLVED → VERIFIED
Hardware: Sun → All
Summary: Stop button doesn't stop DHTML → Stop button doesn't stop JavaScript function
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.