Shift-reload keeps the scroll position stored

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: martijn.martijn, Assigned: vingtetun)

Tracking

Fennec 1.1
Bug Flags:
in-litmus +

Details

(Whiteboard: [need-2.0-ver], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
To reproduce:
- Visit http://jquery.malsup.com/form/#ajaxForm
- Scroll to the bottom of the page
- Hit ctrl-shift-R

Expected result:
A complete reload, browser cache is bypassed, the scroll position is not restored.

Actual result:
A complete reload, browser cache is bypassed, but the scroll position is restored.
(Reporter)

Comment 1

9 years ago
And it makes me wonder whether the zoom level should be remembered on a shift-reload.
(Reporter)

Comment 2

9 years ago
Note to self: I added test for this in https://litmus.mozilla.org/show_test.cgi?id=9802
(In reply to comment #1)
> And it makes me wonder whether the zoom level should be remembered on a
> shift-reload.

It looks like firefox keep it.
Created attachment 442381 [details] [diff] [review]
Patch

Low risk patch that affect a not very common use functionality.
Attachment #442381 - Flags: review?(mark.finkle)
(Reporter)

Comment 5

9 years ago
(In reply to comment #3)
> (In reply to comment #1)
> > And it makes me wonder whether the zoom level should be remembered on a
> > shift-reload.
> 
> It looks like firefox keep it.

Yes, but in firefox, this is part of the site specific preferences. If you zoom in on a page, close Firefox, restart, then the zoom in is also remembered. The use case is for sites that consistently have small font sizes on their site, that some people have trouble reading.
I think Fennec has a different kind of usage pattern, so you might want a different behavior there. Also zoom is not restored on back-forward in history, btw.

Anyway, perhaps a new bug should be filed for this discussion?
(In reply to comment #5)
> (In reply to comment #3)
> > (In reply to comment #1)
> > > And it makes me wonder whether the zoom level should be remembered on a
> > > shift-reload.
> > 
> > It looks like firefox keep it.
> 
> Yes, but in firefox, this is part of the site specific preferences. If you zoom
> in on a page, close Firefox, restart, then the zoom in is also remembered. The
> use case is for sites that consistently have small font sizes on their site,
> that some people have trouble reading.
> I think Fennec has a different kind of usage pattern, so you might want a
> different behavior there. Also zoom is not restored on back-forward in history,
> btw.

I'm agree that the use case is different, as an example because the screen is small you're _force_ to zoom to read the text of a website.

You're probably right after all, but I would like to have Madhava's feedback on this behavior (though Ctrl+shift+R is _not_ a very large audience)

> 
> Anyway, perhaps a new bug should be filed for this discussion?

There is a start of a discussion about per domain zoom in bug 559838, but I won't mind implementing the correct behavior (in term of zoom) for Ctrl + shift + R in this bug.
I think that Shift-reload is a "completely reload the page / reset" function, so not going back to a new state is what we want.  In other words, not remembering zoom level or position.
Created attachment 442690 [details] [diff] [review]
Patch
Assignee: nobody → 21
Attachment #442381 - Attachment is obsolete: true
Attachment #442690 - Flags: review?(mark.finkle)
Attachment #442381 - Flags: review?(mark.finkle)
Obviously the last patch address the zoom/scroll/everything case.
Attachment #442690 - Flags: review?(mark.finkle) → review+
Nice clean patch

pushed m-b:
http://hg.mozilla.org/mobile-browser/rev/b0f738eaff02

shift-reload is not on m-1.1, so I am not pushing there.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.5pre) Gecko/20100503 Namoroka/3.6.5pre Fennec/1.1b2pre
Status: RESOLVED → VERIFIED
Flags: in-litmus+
Whiteboard: [need-2.0-ver]
OS: Windows 7 → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.