Unnecessary space between calendar/tasks shortcut buttons and tab dropdown button

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: ssitter, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 442322 [details]
screenshot of issue

Lightning 1.0b2pre (20100428) with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.5pre) Gecko/20100428 Lanikai/3.1pre.

There is an unnecessary space between the Lightnings shortcut buttons and the tab dropdown button in the tab bar. This happens in a fresh profile with default theme and only Lightning installed.

For users of small screen system like netbooks or subnotebooks this will be annoying in particular because there is no way to remove the buttons to gain space.
(Reporter)

Comment 1

9 years ago
Seems to be related to the new quick search bar button added with Bug 545955. Would it be reasonable to 
a) always show but disable the button to avoid the empty space illusion or
b) collapse the search bar button box if not required to restore space?
'a' would be the more likely option.  We originally were doing 'b', but since it causes the tab bar layout to change when transitioning between quick filter bar capable tabs and non-capable tabs, we moved to just marking the button as invisible so that layout did not change.

The decision to make it invisible rather than disabled was based on the current UI design choice to avoid marking things as disabled that the user has no way of affecting or where the means to enable disabled things are non-intuitive.

Copying clarkbw for his input.

Maybe we can style the space a little better so it doesn't look tantalizing in a disabled state, but also does not look like a completely empty space.
Is this a calendar bug? If not, then I'd like to see this moved to thunderbird land and get the right blocking flags.
I'd like to keep the button hidden.  Having it shown disabled really doesn't make much sense when looking at something like a content tab.  Perhaps we can try to use the space without using a disabled version of the button.  Any ideas?
We could freeze the layout size of the button box, collapse the quick filter bar button, and leave the remaining buttons centered?
(Reporter)

Comment 6

7 years ago
No longer a problem in Thunderbird 11 because the quick search bar button was removed from tab bar and is always visible.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.