All users were logged out of Bugzilla on October 13th, 2018

Incorrect login information will not cause prompt, but put the webdav request into loop

NEW
Unassigned

Status

--
major
9 years ago
7 years ago

People

(Reporter: nmaier, Unassigned)

Tracking

Lightning 1.0b1

Details

(Reporter)

Description

9 years ago
I tried to add a remote calendar (webdav over https; self-signed with exception).
The ics is http-auth basic protected.
I entered the credentials and choose to store them in the login manager. However, I made a typo in the password.
Lightning didn't prompt again.
From then on each time the remote calendar was requested (with each TB start), the nsIHttpChannel went into a request loop, finally failing with 400 because it added a "no-cache" to Cache-Control on each iteration so that the request became too large. I cannot tell if this is due to a bug in nsChannel or lightning (installed notificationCallbacks do not seem to support GetInterface(nsIAuthPrompt)).
The server logged:
[Thu Apr 29 10:56:40 2010] [error] [client 134.169.203.159] user tn123: authentication failure for "/dav/tn123/calendar": Password Mismatch
[Thu Apr 29 10:56:40 2010] [error] [client 134.169.203.159] user tn123: authentication failure for "/dav/tn123/calendar": Password Mismatch
[Thu Apr 29 10:56:40 2010] [error] [client 134.169.203.159] user tn123: authentication failure for "/dav/tn123/calendar": Password Mismatch
...
Note that all these requests come from a single nsIChannel (I checked with quick-n-dirty Cu.reportError debugging in calIICSCalendar.js:prepareChannel()).

Steps:
 * Add http-auth protected remote ICS/WebDav calendar.
 * Enter incorrect credentials when prompted.
 * See the calendar failing to load from now (rootComp is null in console)

Fix:
 * Manually remove the login via Preferences/Saved passwords, restart TB and enter correct credentials when prompted.

Comment 1

8 years ago
I had the same problem.  I changed my password on the server and thunderbird correctly re-prompted me for mail passwords, but lightning did not.  It simply failed to load calendars.  There were no messages in the error console, even when I enabled debug and verbose debug logging.  I discovered the problem by looking at apache logs on my server.  Every 2 seconds a 401 (unauthorized) error showed up in the logs for each calendar it attempted to load.

server log example:
xx.xx.xx.xx - zach [10/Aug/2010:09:36:45 -0500] "GET /calendar/zach.ics HTTP/1.1" 401 399 "-" "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.11) Gecko/20100713 Lightning/1.0b2pre Thunderbird/3.0.6"

Manually removing the password from saved passwords to get a new prompt fixed it for me, too.
Does this still happen with Lightning 1.0? I believe we've fixed some related issues in the meanwhile.

Comment 3

7 years ago
I have changed to using a caldav server, so my test isn't really apples-to-apples anymore.  But, I changed the password and lightning prompted me for a new password.  So this work properly for me now (at least using caldav instead of http/ics).
You need to log in before you can comment on or make changes to this bug.