Crash [@ FlashPlayer-10.4-10.5@0x603d78] [@ Flash Player@0x4aa8c8 ]

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: bc, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:vector-? (flash)][FlashPlayer 10.1.53.55], crash signature, URL)

(Reporter)

Description

9 years ago
load http://www.fmsrilanka.com/ with Flash 10.1.53.21

1.9.3/mac x86

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x1c4ac227
[Switching to process 82447 thread 0xc923]
0xffff07fc in ?? ()
(gdb) bt
#0  0xffff07fc in ?? ()
#1  0x00000000 in ?? ()

1.9.3 /mac ppc
Operating system: Mac OS X
                  10.5.8 9L34
CPU: ppc
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0xa638a00

Thread 17 (crashed)
 0  0xffff8914
   srr0 = 0xffff8914    r1 = 0xf0921ae0
 1  FlashPlayer-10.4-10.5 + 0x603d78
   srr0 = 0x112bcd7c    r1 = 0xf0921b40
 2  FlashPlayer-10.4-10.5 + 0x60e410
   srr0 = 0x112c7414    r1 = 0xf0921ba0
 3  FlashPlayer-10.4-10.5 + 0x176fac
   srr0 = 0x10e2ffb0    r1 = 0xf0921c10
 4  FlashPlayer-10.4-10.5 + 0x177614
   srr0 = 0x10e30618    r1 = 0xf0921d10
 5  FlashPlayer-10.4-10.5 + 0x261b78
   srr0 = 0x10f1ab7c    r1 = 0xf0921d70
 6  FlashPlayer-10.4-10.5 + 0x264140
   srr0 = 0x10f1d144    r1 = 0xf0921f40
 7  FlashPlayer-10.4-10.5 + 0x3a954c
   srr0 = 0x11062550    r1 = 0xf0921fa0
 8  CoreAudio + 0xe7c4
   srr0 = 0x7000e7c8    r1 = 0xf0922330
 9  CoreAudio + 0xdda4
   srr0 = 0x7000dda8    r1 = 0xf0922390
10  CoreAudio + 0xcf60
   srr0 = 0x7000cf64    r1 = 0xf0922400
11  AudioToolbox + 0x7c0c
   srr0 = 0x96b93c10    r1 = 0xf0922450
12  AudioToolbox + 0x77d0
   srr0 = 0x96b937d4    r1 = 0xf09224c0
13  AudioToolbox + 0x7714
   srr0 = 0x96b93718    r1 = 0xf0922540
14  AudioToolbox + 0x7568
   srr0 = 0x96b9356c    r1 = 0xf09225a0
15  AudioToolbox + 0x72f0
   srr0 = 0x96b932f4    r1 = 0xf0922620
16  AudioToolbox + 0x7460
   srr0 = 0x96b93464    r1 = 0xf09226a0
17  AudioToolbox + 0x72f0
   srr0 = 0x96b932f4    r1 = 0xf0922700
18  AudioToolbox + 0x1cd44
   srr0 = 0x96ba8d48    r1 = 0xf0922780
19  CoreAudio + 0xcacc
   srr0 = 0x7000cad0    r1 = 0xf09227f0
20  CoreAudio + 0x5d00
   srr0 = 0x70005d04    r1 = 0xf0922880
21  CoreAudio + 0x11408
   srr0 = 0x7001140c    r1 = 0xf0922910
22  CoreAudio + 0x35620
   srr0 = 0x971f7624    r1 = 0xf0922a90
23  CoreAudio + 0x352ac
   srr0 = 0x971f72b0    r1 = 0xf0922af0
24  CoreAudio + 0x35160
   srr0 = 0x971f7164    r1 = 0xf0922b60
25  CoreAudio + 0x33b30
   srr0 = 0x971f5b34    r1 = 0xf0922cb0
26  CoreAudio + 0x337f0
   srr0 = 0x971f57f4    r1 = 0xf0922e00
27  CoreAudio + 0x21de4
   srr0 = 0x971e3de8    r1 = 0xf0922e50
28  libSystem.B.dylib + 0x430d0
   srr0 = 0x968380d4    r1 = 0xf0922ea0

1.9.3/winxp OOPP showed crash once. Haven't been able to reproduce.

bp-4bebae2e-343a-47ee-a974-2b9482100429

Comment 1

9 years ago
I just reproduced.  Site takes quite a while to load so waiting around several miniutes might be required.

Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100416 Minefield/3.7a5pre

Shockwave Flash 10.0 r42

http://crash-stats.mozilla.com/report/index/bp-2c20c72f-a416-4613-b0de-388be2100429

Frame  	Module  	Signature [Expand]  	Source
0 		@0xffff07fc 	
1 	Flash Player 	Flash Player@0x4aa8c8 	
2 	Flash Player 	Flash Player@0x4adf26 	
3 	Flash Player 	Flash Player@0x4aa0ad 	
4 	Flash Player 	Flash Player@0xbf2ba 	
5 	Flash Player 	Flash Player@0xbf89c 	
6 	Flash Player 	Flash Player@0x138420 	
7 	Flash Player 	Flash Player@0x139deb 	
8 	Flash Player 	Flash Player@0x2e19a1 	
9 	CoreAudio 	CoreAudio@0xefef 	
10 	CoreAudio 	CoreAudio@0xe7f3 	
11 	CoreAudio 	CoreAudio@0xdb4a 	
12 	AudioToolbox 	AudioConverterChain::CallInputProc 	
<snip>

looks like we get 40-60 of these per day over the last week.

checking --- Player@0x4aa8c8 20100426-crashdata.csv
found in: 3.6.3 3.5.9 3.6.2 3.6 3.6.4 3.5.4 3.5.8 3.5.2 3.0.19 3.0.15 3.0

os breakdown
Player@0x4aa8c8
  38 Mac OS X 10.5 Flash Player@0x4aa8c8
  24 Mac OS X 10.6 Flash Player@0x4aa8c8

other test urls

   2 http://www.rmc.fr/front_office/player.html
   2 http://www.miracleschool.net/webinars/celebrationwebinar26apr2010
   2 http://noticiasmvs.com/mvsPlayer/mvsPlayer.php
   1 https://www.ourtv.hk/cgi-bin/ourdb/bdetail?session_id=start&share=ourdb@ourtv.hk&dbname=vid_Video&template=344118260202&caller=https://www.ourtv.hk/cgi-bin/ourdb/bdetail&acti
on=vid_Video,344118260202,1553&key=1552
   1 https://accounts.craigslist.org/post/shwpst?pii=1690154525&db=lv
   1 http://www.x-rater.net/ot_songlist.php?un=catherineb77290088&pw=67320
   1 http://www.team990.com/streaming/player/flash/index.php?alt=0
   1 http://www.talkshoe.com/talkshoe/web/talkCast.jsp?masterId=12986&cmd=tc
   1 http://www.rmc.fr/front_office/sport_player.html
   1 http://www.orange.fr/
   1 http://www.imer.com.mx/phpwrappers/player3/webradioReactor.html
   1 http://www.facebook.com/board.php?uid=321011405118#!/topic.php?uid=321011405118&topic=15240
   1 http://www.facebook.com/?ref=home#!/manny.rey1
   1 http://www.eluniversal.com.mx/noticias.html
   1 http://www.edg3.co.uk/snatch/life.jpg
   1 http://www.aojimetro.com.mx/media/flash/
   1 http://www.animelodia.com/foros/
   1 http://waterlooinsider.wordpress.com/wp-admin/
   1 http://tva.canoe.ca/emissions/galaartis2010/photos/
   1 http://transcontinentalfm.radio.de/
   1 http://talk-a-latte.com/chat/
   1 http://sfdcradio.com/top.html
   1 http://sanganam.com/cara-membuat-radio-streaming-atau-radio-internet.html
   1 http://ru.wikipedia.org/wiki/%D0%98%D1%81%D1%82%D0%BE%D1%80%D0%B8%D1%8F_%D0%98%D0%A1%D0%9A%D0%9A%D0%9E%D0%9D_%D0%B2_%D0%A0%D0%BE%D1%81%D1%81%D0%B8%D0%B8
Summary: Crash [@ FlashPlayer-10.4-10.5@0x603d78] → Crash [@ FlashPlayer-10.4-10.5@0x603d78] [@ Flash Player@0x4aa8c8 ]

Comment 2

9 years ago
Chris is it easy to repro?  I'll take a look this morning but could you also try 10.1?  

http://labs.adobe.com/downloads/flashplayer10.html

Comment 3

9 years ago
yeah, it was pretty easy for me to hit the crash.  just loaded the test url and waited for the page to load.

from the 62 reports received on 4/26 here was the breakdown
  51 Flash Player 266780DB53C4AAC830AFF69306C5C0300  10.0.42.34 on x86 
  11 Flash Player D1AAAB5D417861E6A5B835B01D3039550  10.0.45.2 on x86
(Reporter)

Comment 4

9 years ago
charles, my reports were with 10.1rc2: Flash 10.1.53.21

Comment 5

9 years ago
Nice one.  I've reproduced this issue on our mainline.

Updated

9 years ago
Whiteboard: [sg:vector-? (flash)]
Keywords: testcase-wanted

Comment 6

9 years ago
Fixed in Flash Player 10.1.53.55
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [sg:vector-? (flash)] → [sg:vector-? (flash)][FlashPlayer 10.1.53.55]
(Assignee)

Updated

8 years ago
Crash Signature: [@ FlashPlayer-10.4-10.5@0x603d78] [@ Flash Player@0x4aa8c8 ]

Updated

3 years ago
Group: core-security → core-security-release
Keywords: testcase-wanted
Group: core-security-release

Comment 7

3 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 10.x → unspecified
You need to log in before you can comment on or make changes to this bug.