Html entities not rendered in title bar

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Alessio "Spinus" Moscatello, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

Html entities are not rendered in title bar on Windows XP (not sure if the problem occurs in other platforms)
The issue is present in both Firefox 3.6.3 and latest 3.7


Reproducible: Always

Steps to Reproduce:
1. Create a simple HTML page
2. Insert a title containing an HTML entity (e.g. ❶)
3. Open the page with Firefox

Actual Results:  
Html entity is correctly displayed in the tab's title and in the tab's tool tip, but not in the title bar
Had you recently opened a PDF?  See bug 512032.
(Reporter)

Comment 2

8 years ago
Yes,I use Pdfs every day...so I've tried using a fresh profile and the problem still persists
Reporter, please retest with Firefox 3.6.12 or later in a fresh profile (http://support.mozilla.com/kb/Managing+profiles). Also update your plugins (flash, adobe reader, java, quicktime, silverlight, etc.) Go to the developer's website and download the latest version from there. If you no longer see this issue, please close this bug as RESOLVED, WORKSFORME. If you do see the bug, please post a comment.
Whiteboard: [CLOSEME 2010-12-01]
(Reporter)

Comment 4

7 years ago
I've tested Firefox 3.6.12 and Firefox 4 nightly under Windows Xp and the problem still occurs.
As soon as possible I'll test if the issue is present running Firefox under Linux.

I'm attaching a simple html page that triggers the problem.
(Reporter)

Comment 5

7 years ago
Created attachment 490533 [details]
Html page to test the problem

In my pc the first two html entities of the title are displayed correctly in the page, in the title of the tab, but not in the title bar.

Updated

7 years ago
Whiteboard: [CLOSEME 2010-12-01]
Version: unspecified → Trunk
(Reporter)

Comment 6

7 years ago
Using Ubuntu 10.10 the problem doesn't occurs...

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.