Upgrade nsis WinVer.nsh for Win7 detection support

RESOLVED WONTFIX

Status

mozilla.org
MozillaBuild
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Details

We currently just use a zip of NSIS wholesale. Do you want a new version of NSIS, or just to overwrite this one file separately?
Jim, instead of updating this one NSIS file in mozilla-build the required code can be added with a different name to either overrides.nsh or common.nsh so we don't require everyone to update including the tinderboxes. btw: at some point we should update all of NSIS in mozilla-build but our code needs to be updated to do this.
(Reporter)

Comment 3

8 years ago
I'm not going to need the version code for the work I'm doing, so this should be converted over to a generic, "upgrade nsis" bug, or if we already have a method of tracking that, this bug can be closed out.
Sounds fine but how about just loading / using that dll in that other bug when it is needed (e.g. Win7 and greater) which should remove the issue with dependencies?
jimm, rs, chosen status here?
As reported I'm tempted to just wontfix this and when we're ready to take on upgrading NSIS in mozilla-build just filing new bugs since it will require changes to the code as well.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.