Form helper should disappear when reloading the page

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: vingtetun)

Tracking

Fennec 1.1
x86
Windows 7

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
To reproduce:
- Go to http://google.com
- Click on the input, to invode the form helper
- Press ctrl-R or press the reload button in the url bar

Expected result:
- Form helper should disappear

Actual result:
- Form helper is still there
tracking-fennec: --- → ?
agreed - reloading should be "resetting" the page
Whiteboard: mobile-triage
Assignee: nobody → 21
Whiteboard: mobile-triage
Created attachment 455424 [details] [diff] [review]
Patch

I've test this patch on google.com, then on http://translate.google.fr/translate_t?hl=&ie=UTF-8&text=tres&sl=en&tl=fr#en|fr|t by trying to type letters and also refresh the page (the interesting part of this website is the hash changes)
Attachment #455424 - Flags: review?(mark.finkle)
Created attachment 455557 [details] [diff] [review]
patch v0.2

As seen on IRC, I've encapsulated the Form Helper case where he is closing.
For now I've add a handleEvent on FormMessageReceiver but this will move soon since this will be removed with the clean up of the form assistant code in browser-ui.js (bug 573560)
Attachment #455424 - Attachment is obsolete: true
Attachment #455424 - Flags: review?(mark.finkle)
Attachment #455557 - Flags: review?(mark.finkle)
Attachment #455557 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/75ef1fd7653e
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 5

6 years ago
Not reproducible with:
Mozilla/5.0(Windows NT 5.1; rv:10.0a1) Gecko/20111018 Firefox/10.a1 Fennec/10.a1

Verifying.
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.