All users were logged out of Bugzilla on October 13th, 2018

After changing Themes mail body for non-ascii messages is garbled

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
18 years ago
a year ago

People

(Reporter: marina, Unassigned)

Tracking

({intl})

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-])

(Reporter)

Description

18 years ago
**** observed with 2000-10-12 build ****
Steps to reproduce:
- go to Preferences and change Themes from Modern to classic;
- come back to Messenger;
- select a message (any: JA, French, Cyrillic);
//note: header in the thread and header in the message body are fine but the
body itself is garbled

Comment 1

18 years ago
I can reproduce this with win32 branch build ID2000101108.
Work around is to create a new thread pane.
Status: NEW → ASSIGNED
(Reporter)

Comment 2

18 years ago
Latin--2 languages are garbled in the thread as well (for Subject and sender 
name)
(Reporter)

Comment 3

18 years ago
adding rtm keyword, i think it's pretty serious
Keywords: rtm
*** Bug 56277 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

18 years ago
After switching Themes the Latin-2 entries in  Address Book are garbled. Naoki, 
do i leave as comments here or enter a new bug for AB? 

Comment 6

18 years ago
Frank, can you triage this bug?

Updated

18 years ago
Target Milestone: --- → M23

Updated

18 years ago
Whiteboard: [rtm-]

Comment 7

18 years ago
marina, can you re-test this for the current build?

Updated

18 years ago
Keywords: intl, nsbeta1

Comment 8

18 years ago
Mass change to bugs filed by marina --> QA contact to marina.
thanks!
QA Contact: momoi → marina

Updated

18 years ago
Target Milestone: --- → mozilla0.8

Comment 9

18 years ago
Adding mscott to cc, do you know any possibility that libmime might be affected
by the theme change?

Comment 10

18 years ago
MIME sends UTF-8 to layout, so messenger notify it by setting a force charset.
But after the theme change, the force charset seems to be reset. So input to 
layout is not recognized as UTF-8.
If I open a message as a stand alone, the message is shown correctly.
Also if I set 'mCharsetInitialized' false manually (in debuger) the message is 
shown correctly because it forces a charset back to UTF-8.
Scott, please take a look at this.

void
nsMessenger::InitializeDisplayCharset()
{
  if (mCharsetInitialized)
    return;

  // libmime always converts to UTF-8 (both HTML and XML)
  if (mDocShell) 
  {
    nsAutoString aForceCharacterSet; 
aForceCharacterSet.AssignWithConversion("UTF-8");
    nsCOMPtr<nsIContentViewer> cv;
    mDocShell->GetContentViewer(getter_AddRefs(cv));
    if (cv) 
    {
      nsCOMPtr<nsIMarkupDocumentViewer> muDV = do_QueryInterface(cv);
      if (muDV) {
        muDV->SetForceCharacterSet(aForceCharacterSet.GetUnicode());
      }

      mCharsetInitialized = PR_TRUE;
    }
  }
}
Assignee: nhotta → mscott
Status: ASSIGNED → NEW
Target Milestone: mozilla0.8 → ---

Comment 11

18 years ago
marking nsbeta1-.  Need to get theme switching for message pane to work first.
Keywords: nsbeta1 → nsbeta1-

Comment 12

18 years ago
Scott, I don't know about getting theme switching to work first, but this
problem seems serious with any theme change. Marina, can you comment on the bug?

Comment 13

18 years ago
That's why we have a big warning when you switch themes which says "be sure to
close all mail windows". docshell's and such tend to become detached when you
switch themes. this bug should be marked a dup of that one.....we still have a
lot of theme switching work to do.

Updated

18 years ago
Severity: critical → normal

Comment 14

18 years ago
I think Scott is correct, the warning always shows up on-top for me. Please let
us know, if you see something different. Agree with the nsbeta1- for now.

Comment 15

18 years ago
Marina - If you and Jenn agree on MScott's message, that this is as designed, we 
should close this as invalid.
(Reporter)

Comment 16

17 years ago
the verification of this bug is blocked by bug 116038 though i don't think it is
happening in the latest builds
Product: MailNews → Core
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
Assignee: mscott → nobody
QA Contact: marina → i18n

Comment 17

a year ago
Based on the last old comments, I think this should be closed, so closing..
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.