Fails to add a tag in Zamboni (get a 400 Bad Request error)

VERIFIED INVALID

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED INVALID
8 years ago
2 years ago

People

(Reporter: stephend, Unassigned)

Tracking

5.10
x86
Windows 7

Details

(Whiteboard: [z], URL)

(Reporter)

Description

8 years ago
Rather than reopening bug 560415, I filed this anew.

STR:

1. Log in
2. Load https://preview.addons.mozilla.org/z/en-US/firefox/addon/5579/
3. Try to add a tag

Actual Results:

Fails to add a tag:

https://preview.addons.mozilla.org/en-US/firefox/tags/add

POST /en-US/firefox/tags/add HTTP/1.1
Host: preview.addons.mozilla.org
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Accept: */*
Accept-Language: en,en-us;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
Connection: keep-alive
Content-Type: application/x-www-form-urlencoded; charset=UTF-8
X-Requested-With: XMLHttpRequest
Referer: https://preview.addons.mozilla.org/z/en-US/firefox/addon/5579/
Content-Length: 31
Cookie: WT_FPC=id=2dcdeefaf4d016b45771272494088283:lv=1272572531760:ss=1272571324425; wtspl=945477; amo_home_promo_seen=5; csrftoken=b3d344c7160de1a46acb3e1d1d7333bf; sessionid=ca550d27fd6cbc5902597886437a2769
Pragma: no-cache
Cache-Control: no-cache
newTag=fail&addonid=5579&ajax=1
HTTP/1.1 400 Bad Request
Server: Apache
X-Backend-Server: pm-app-amo24
Content-Type: text/html; charset=UTF-8
Date: Thu, 29 Apr 2010 21:22:22 GMT
X-AMO-ServedBy: pm-app-amo24.mozilla.org
Via: Moz-Cache-zlb03
Connection: close
X-Powered-By: PHP/5.2.9
X-Cache-Info: not cacheable; request wasn't a GET or HEAD
Content-Length: 681
(Reporter)

Comment 1

8 years ago
Oh, and here's a somewhat-lengthy screencast (which also shows some random session problem that I can't readily reproduce):

http://www.screencast.com/users/stephendonner/folders/Jing/media/a606f659-f479-4606-82b8-d9c4932c0529
talked to stephend
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> talked to stephend

OK, so, for posterity: this particular case happened because I was logging in to the add-on details page using Zamboni, and so I had no Remora login.

Verified INVALID; glad I got a chance to talk to Wil in person.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.