Exception to allow cookies from a site does not stick

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: james, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0

in Tools->Options->Privacy->Accept Cookies from Sites->Exceptions, when i set an exception to allow a site (e.g. if I want to always allow cookies from Facebook.com), the setting is lost next time I start up FireFox.

Reproducible: Always

Steps to Reproduce:
1. Set privacy with "Accept cookies from sites" checked
2. Set "accept third-party cookies" to unchecked
3. Set "Keep until:" to "I close Firefox"
4. Set "Clear history when Firefox closes" to checked
5. Click "Exceptions...", add "facebook.com", and click "Allow"
6. Exit from dialogs
7. Close Firefox
8. Open Firefox, go to exceptions menu - "facebook.com" exception will be gone
Actual Results:  
The site-specific allow exception I added was gone after restart.
After restart, cookies were not retained for the exception website.

Expected Results:  
Exception should persist over firefox close and restart.
For the website specified in the allow exception, cookies should be retained through firefox close and restart.

Comment 1

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100513 Firefox/3.6.4
It works for me. Please update if it works fine by creating a new profile. 
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile.
(Reporter)

Comment 2

8 years ago
Just upgraded to Firefox 3.6.6.  
Still have the same thing.
Can't make any exceptions stick.
(Reporter)

Comment 3

7 years ago
aravindm - 
Creating a new profile fixed this problem for me.  I did not know to try that.
Thanks for the help.  

I guess this one just gets chalked up to profile corruption.  A little too vague to report, but hopefully something folks are working on cleaning up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.