Closed Bug 562853 Opened 9 years ago Closed 9 years ago

Cannot undo uninstall of an extension that was already disabled

Categories

(Toolkit :: Add-ons Manager, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 553494

People

(Reporter: jruderman, Unassigned)

References

Details

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100429 Firefox/3.7a5pre

Steps to reproduce:
1. Tools > Add-ons > Extensions.
2. Click "Remove" for an extension that is already disabled.
3. Click "Undo" in the yellow bubble.

Result: Nothing happens, except that an error appears in the error console.

Error: Add-on is not marked to be uninstalled
Source File: file:///Users/jruderman/central/opt-obj/dist/Firefox.app/Contents/MacOS/modules/XPIProvider.jsm
Line: 4475
This is because disabled addons are uninstalled immediately (without needing a restart). It will probably be fixed by solving bug 553494.
Depends on: 553494
OS: Mac OS X → All
Hardware: x86 → All
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553494
You need to log in before you can comment on or make changes to this bug.