Clash of modal dialogs (unresponsive script vs file save as) hangs entire UI

RESOLVED DUPLICATE of bug 476541

Status

()

--
critical
RESOLVED DUPLICATE of bug 476541
8 years ago
8 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/531.22.7 (KHTML, like Gecko) Version/4.0.5 Safari/531.22.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

After an attempt to download a file from virtualbox.org failed due to some server error, I attempted to download that file again (via the Save link as... popup menu) without deleting the partially downloaded file.  Firefox popped up a dialog asking whether or not to replace the file.  I elected to replace the file but when I was returned to the file save as dialog, hitting save did nothing (I stayed stuck in the save as dialog).  I went to a shell and manually deleted the file and tried again, but the save button still did nothing. I tried to cancel from the save as dialog, but that also did nothing, leaving the save as dialog still visible and active.

At that point I probably moved the save as dialog and discovered that underneath that dialog, the "unresponsive script" alert had popped up.  I could not dismiss the unresponsive script alert because it did not respond at all to the mouse.  It would appear that both the save as dialog and the unresponsive script alert are modal dialogs, and are preventing each other from completing (that fact that I can't even *cancel* the save as dialog is a worry).  The result is the entire Firefox session (13 windows with up to a dozen or so tabs in each window (I like to maintain a *lot* of browsing state)) is hung with no means of recovery without force quitting Firefox and restoring the session.

According to the unresponsive script alert, the offending script is:

    chrome://global/content/bindings/general.xml:0

This looks to me like it isn't something on the page I was browsing taking too long, rather Firefox itself is running some kind of script while popping up a modal dialog, then getting upset when the user takes too long to respond. But I could be wrong, because I can't find the exact steps to reproduce the problem.  But in general, care needs to be taken with modal windows to ensure they can't cause a UI deadlock.

Reproducible: Couldn't Reproduce
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476541

Comment 2

8 years ago
I had the same thing happen to me... I sent to save an image from a site, and while the Save As dialog was open, an "Unresponsive Script" window popped up BEHIND the Save As box. I could not close either box as the background "Unresponsive Script" box could not be accessed by pressing the "Stop Script" button because the Save As window was fighting to keep itself modal. 

I was at the adobe site saving a "Get Adobe Reader" icon for my site and after 20-ish seconds the "Unresponsive Script" window popped up.

Chicken and Egg problem here...

As in the original post above, I always have many windows open and this is a royal pain. I hope you can fix this in the next update!

-Anthony Navarro
You need to log in before you can comment on or make changes to this bug.