pop-up preventing dialog is not shown properly while going back in history

RESOLVED WORKSFORME

Status

Firefox for Android Graveyard
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Chwiej Pawel, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2.5pre) Gecko20100429 Namoroka/3.6.5pre Fennec/1.1b2pre

Maemo 5
fennec_1.1~b2~20100429011515_armel.deb


Reproducible: Always

Steps to Reproduce:
1. Go to http://www.popuptest.com
2. Select Come&Go Test
3. When new page is opened select 'Show' option from the dialog
4. Slide page left and press back button on control tab.

Actual Results:  
Pop-up preventing dialog is shown only for half a second, then it disappears. User can't select any option.


Expected Results:  
Pop-up preventing dialog should be displayed properly even while navigating back in history, allowing user to read it and eventually choose an option.

Updated

8 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
Hardware: Other → ARM

Comment 1

7 years ago
works for me. Would you check a recent build? http://www.mozilla.com/m/beta

http://hg.mozilla.org/mozilla-central/rev/9a6de1e28d4b
Mozilla/5.0 (Android; Linux armv7l; rv:2.0b10pre) Gecko/20110124 Firefox/4.0b10pre Fennec/4.0b4pre ID:20110124051252
HTC G2 - Android 2.2

Comment 2

7 years ago
Address should be http://www.firefox.com/m/beta/

Comment 3

7 years ago
Disregard comment 2, the trailing slash causes a 404.

Comment 4

7 years ago
This works for me.

Build ID: Mozilla/5.0 (Maemo; Linux armv7l; rv:7.0)  Gecko/20110902 Firefox/7.0 Fennec/7.0
Device: Nokia N900 - Maemo5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.