Last Comment Bug 562884 - Non-Firefox apps fail running test_fuel.js with "TypeError: AM_Cc['@mozilla.org/fuel/application;1'] is undefined"
: Non-Firefox apps fail running test_fuel.js with "TypeError: AM_Cc['@mozilla.o...
Status: VERIFIED FIXED
[rewrite]
:
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: Trunk
: All All
: P1 major (vote)
: mozilla1.9.3a5
Assigned To: Dave Townsend [:mossop]
:
: Andy McKay [:andym]
Mentors:
Depends on:
Blocks: 552731
  Show dependency treegraph
 
Reported: 2010-04-30 03:23 PDT by Mark Banner (:standard8, limited time in Dec)
Modified: 2010-05-18 06:16 PDT (History)
4 users (show)
dtownsend: in‑testsuite+
dtownsend: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch rev 1 (1.31 KB, patch)
2010-05-05 12:03 PDT, Dave Townsend [:mossop]
robert.strong.bugs: review+
Details | Diff | Splinter Review

Description Mark Banner (:standard8, limited time in Dec) 2010-04-30 03:23:39 PDT
Non-Firefox apps will fail when running test_fuel.js due to:

/buildbot/linux-comm-central-check/build/objdir/mozilla/_tests/xpcshell/test_extensionmanager/xpcshell/test_fuel.js:51: TypeError: AM_Cc['@mozilla.org/fuel/application;1'] is undefined

I can see several possibilities for fixes:

- List each application in the test
- Harmonise the different ids into one, so that each application used the same.
- Move test_fuel.js under browser/ and maybe duplicate for each app.
- Use the build system to generate a function to get the equivalent of fuel for each app.
Comment 1 Henrik Skupin (:whimboo) 2010-04-30 05:24:47 PDT
Mmh, is it a left-over from the patch on bug 552731?
Comment 2 Mark Banner (:standard8, limited time in Dec) 2010-04-30 06:42:50 PDT
(In reply to comment #1)
> Mmh, is it a left-over from the patch on bug 552731?

I wouldn't have said a left-over. Incorrect assumption in writing the test maybe.
Comment 3 Dave Townsend [:mossop] 2010-04-30 07:38:00 PDT
So FUEL isn't always present, when it is present does it sometimes have different contract IDs?

I could probably look up the contract ID in the category manager registration for the Application global object and go from there.
Comment 4 Mark Banner (:standard8, limited time in Dec) 2010-04-30 07:44:23 PDT
Thunderbird's id is: "@mozilla.org/steel/application;1"

SeaMonkey's id is: "@mozilla.org/smile/application;1"
Comment 5 Dave Townsend [:mossop] 2010-05-05 12:03:48 PDT
Created attachment 443687 [details] [diff] [review]
patch rev 1

This looks up the Application contract ID in the category manager and exits if it is not found or if whatever is there is not an extIApplication.
Comment 6 Dave Townsend [:mossop] 2010-05-05 15:01:17 PDT
http://hg.mozilla.org/projects/addonsmgr/rev/d2bf8e542e98
Comment 7 Dave Townsend [:mossop] 2010-05-11 11:23:19 PDT
http://hg.mozilla.org/mozilla-central/rev/2a6fde3b2211
Comment 8 Henrik Skupin (:whimboo) 2010-05-18 06:16:55 PDT
Verified fixed by checkin and a green test-run.

Note You need to log in before you can comment on or make changes to this bug.