Add-on details UI in localized builds is broken: "(disabled)", no name or description, buttons do not work except for the rating

VERIFIED FIXED in mozilla1.9.3a5

Status

()

defect
P1
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Aleksej, Assigned: Unfocused)

Tracking

Trunk
mozilla1.9.3a5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewriteTestday][rewrite])

Attachments

(1 attachment)

Mozilla/5.0 (X11; U; Linux i686; eo; rv:1.9.3a5pre) Gecko/20100430 Minefield/3.7a5pre

The add-ons can still be found by name.
Not sure if this is an API or front-end bug. I suspect it could be API related.
Blocks: 461973
Severity: critical → major
OS: Linux → All
Priority: -- → P1
Hardware: x86 → All
Should be fixed by bug 562876.
Blocks: 550048
No longer blocks: 461973
Depends on: 562876
Duplicate of this bug: 562993
Fixed by bug 562877
Depends on: 562877
No longer depends on: 562876
Whiteboard: [AddonsRewriteTestday][rewrite] → [AddonsRewriteTestday][rewrite][fixed-in-addonsmgr]
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [AddonsRewriteTestday][rewrite][fixed-in-addonsmgr] → [AddonsRewriteTestday][rewrite]
Target Milestone: --- → mozilla1.9.3a5
Verified fixed on Linux i686 with Mozilla/5.0 (X11; U; Linux i686; eo; rv:1.9.3a5pre) Gecko/20100512 Minefield/3.7a5pre
Verified fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; fa; rv:1.9.3a5pre) Gecko/20100517 Minefield/3.7a5pre (.NET CLR 3.5.30729)

Blair, anything we would test with an automated test? The manual test will be part of at least another default Litmus test.
Assignee: nobody → bmcbride
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
I wouldn't bother adding a test specifically for this - should be covered by tests elsewhere, since it'll break a *lot* of stuff.
Flags: in-testsuite?
Flags: in-testsuite-
Flags: in-litmus?
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.