update add-ons [text/link] is difficult to read

VERIFIED FIXED in mozilla2.0b8

Status

()

P2
normal
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Peter6, Assigned: Unfocused)

Tracking

Trunk
mozilla2.0b8
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 442710 [details]
screenshot

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100430 Minefield/3.7a5pre ID:20100430040256

repro:
open FF
open add-ons manager
find a way to manually update

expected:
something detectable with the naked eye ;-)

result:
a hard to find link.
Does this mix -moz-nativehyperlink in foreground with hardcoded colors in the background?
This will completely change with the work on bug 562622. See the design mockups attached there.

Blair, marking as WONTFIX?
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [AddonsRewriteTestday][rewrite]
My -moz-nativehyperlink question applies to all links in EM UI.
Priority: -- → P2
(In reply to comment #3)
> My -moz-nativehyperlink question applies to all links in EM UI.

That will be fixed by bug 563565 - which will be sorted out once we have a more final visual design (current colors are temporary).
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(In reply to comment #2)
> This will completely change with the work on bug 562622. See the design mockups
> attached there.
> 
> Blair, marking as WONTFIX?

Since removing the link is a perfectly valid solution to this bug, the right work flow is to mark this fixed when the link has been removed. However, attachment 442478 [details] still contains links (fourth and fifth step).
Status: RESOLVED → REOPENED
Depends on: 563565, 562622
Resolution: WONTFIX → ---
blocking2.0: --- → final+
Assignee: nobody → bmcbride
This text is not even there anymore. Close?
(In reply to comment #6)
> This text is not even there anymore. Close?

Is it gone throughout all states? (see attachment 442478 [details])
(In reply to comment #6)
> This text is not even there anymore. Close?

The specific text that's shown in the screenshot is gone, but there are still other cases. And yes, they still use -moz-nativehyperlinktext on top of hardcoded background colors (soon to be textures).
Blocks: 586066
Duplicate of this bug: 591743
Duplicate of this bug: 597803
Whiteboard: [AddonsRewriteTestday][rewrite] → [needs 601022]
Fixed by bug 601022, file any remaining issues separately
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
Whiteboard: [needs 601022]
Target Milestone: --- → mozilla2.0b8
Marking as verified fixed with builds on all platforms like Mozilla/5.0 (X11;
Linux i686; rv:2.0b8pre) Gecko/20101125 Firefox/4.0b8pre ID:20101125030318

Now we are showing "View Available Updates" at the left side of the utility button once updates are available. The link looks good to me now.
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Flags: in-litmus-
Version: unspecified → Trunk
No longer blocks: 623199
You need to log in before you can comment on or make changes to this bug.