Add memoized function to get config values from the db

RESOLVED FIXED in 5.11.2

Status

addons.mozilla.org Graveyard
Code Quality
P5
normal
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: clouserw, Assigned: davedash)

Tracking

unspecified
5.11.2

Details

(Whiteboard: [qa-])

(Reporter)

Description

8 years ago
We have (or will have) a lot of values in the database that won't change often and will be used on every single request.  These will be stored in memcache, but we should store them closer to the app servers too.  Answer:  memoize them.

The django decorator is here: http://code.djangoproject.com/browser/django/trunk/django/utils/functional.py#L118

When we do change the values (this is primarily for log levels and cron priorities at first) it would be nice if the value changed immediately.  I don't know if we can do that in this case, but that should be investigated too.

Updated

8 years ago
Duplicate of this bug: 559851
(Reporter)

Updated

8 years ago
Assignee: nobody → jbalogh
(Reporter)

Updated

8 years ago
Priority: -- → P5
(Reporter)

Updated

8 years ago
Target Milestone: 5.11 → 5.12
Assignee: jbalogh → dd
http://github.com/jbalogh/zamboni/commits/8f3c496
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]
Target Milestone: 5.12 → 5.11.2
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.