Forecastfox fails to load on startup

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: David Jackson, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100430 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100430 Minefield/3.7a5pre

With latest nightly, forecastfox extension fails to load with following error:
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS
'[JavaScript Error: "Cc['@mozilla.org/extensions/manager;1'] is undefined" {file: "chrome://forecastfox/content/ping/ping-service.js" line 86}]' when calling method: [ffIPingService::start]

Reproducible: Always

Steps to Reproduce:
1.Start firefox
2.
3.
Actual Results:  
Error message appears and forecastfox does not load

Expected Results:  
forecast fox loads without error

Updated

8 years ago
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Version: unspecified → Trunk

Comment 1

8 years ago
Report issues with non-Mozilla addons to their authors. -> INVALID

Undefined extension manager errors are due to the Addon Manager API overhaul. (it landed on Trunk then was backed out and will land again) This is a major change and many extensions will need to be updated to support it. -> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.