Closed Bug 563031 Opened 10 years ago Closed 10 years ago

Check places.{dtd,properties} for unused strings and get rid of them

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 374491

People

(Reporter: kairo, Unassigned)

Details

Attachments

(2 files)

Working on SeaMonkey places bookmarks, I'm stumbling over a number of unused strings in places.{dtd,properties} which look like they're also unused in Firefox. The strings in those files should be checked and ideally we can remove a number of unused ones.
I wrote a small tool (as a PHP commandline script *g*) that goes through all strings in a .dtd or .properties file and does a grep on that identifier in some specified source directories or files. Primitive, but more effective than examining everything manually. ;-)

This is the output of the script for places.dtd and looking in source paths browser/components/places/ and browser/base/content/ for matches.

Note that there are still false positives in that output, so going through the output is a good idea, e.g. I suspect that backCmd.label/forwardCmd.label are actually not used from this file anywhere.
False negatives in the .dtd should be pretty unlikely, in the .properties they're more easily possible, but "NOT FOUND" entries are suspect and very possibly can be removed.
Here's the output of same tool running on places.properties.

I'll leave the actual patching to experiences places people, but I hope that output proves helpful in taking some unneeded work off localizers' shoulders :)
sounds like the same as bug 374491, can you please check if that bug has anything you missed and merge it here?
(In reply to comment #3)
> sounds like the same as bug 374491, can you please check if that bug has
> anything you missed and merge it here?

Hmm, looks like the purpose of both bugs is the same, only that I have some more and very current data here to investigate. The ones in bug 374491 comment #3 are probably in my data here as well, as I remember removing those from my local SeaMonkey patches after using the same script on those files.

Note that even my data needs investigation from someone from the places team, and probably someone of you guys to do the actual patching, as my time is pretty much booked out. I just did write up the script to clean up the somewhat modified SeaMonkey files and thought it would be a good idea to give you that data so you can do such a cleanup on the Firefox side as well.
since now we have patches there, i'm duping this one.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 374491
oh, and thanks for the analysis!
You need to log in before you can comment on or make changes to this bug.