If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tags implementation on addons detail page is craptastical

RESOLVED DUPLICATE of bug 600685

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED DUPLICATE of bug 600685
8 years ago
2 years ago

People

(Reporter: davedash, Unassigned)

Tracking

Details

Need some design ideas.

Let's assume a popular addon (E.g. adblock plus).

Let's say it has tags from users:

ad ad ads foo bar

so we'd display:

ad
ads
foo
bar

If I was one of the two people to tag this addon as "ad."  In theory a red x
will show up.  The page will reload and internally we'll know we have the
following tags:

ad ads foo bar

and display:

ad
ads
foo
bar

same as before -- confusing user behavior.

It might be nice to indicate which tags are your tags and which aren't.  We
could use a different icon, or split them up in the display... e.g:

Your Tags:
ad

Everyones Tags:
ad
ads
foo
bar

or optionally omit your tags from Everyones Tags.

I prefer splitting them as it's more obvious that 1. which tags I *can* delete
and 2. that if I delete a tag, it may still be present, but at least not under
*my* tags.

Thanks,

-d

Updated

8 years ago
Duplicate of this bug: 563385

Updated

8 years ago
Component: Developer Pages → Public Pages
OS: Mac OS X → All
QA Contact: developers → web-ui
Hardware: x86 → All

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 600685
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.