If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

There is issues with the content images and links, only seems to happen with Firefox.

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Kevin, Unassigned)

Tracking

1.9.2 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729)

I've checked this issue with some other top browers and don't see the issue of images being misplaced. Only do I experience the issue with Firefox browser. It happens with all O.S. with Firefox too. http://www.filthgauge.com/Bio.htm 

Reproducible: Always

Steps to Reproduce:
1.Happens instantly when I open the page.
2.
3.
Actual Results:  
Happens instantly when I open the page.

Expected Results:  
I can't do nothing to fix the issue.

The links and images should be in their correct places.
Component: Page Info → General
QA Contact: page.info → general

Comment 1

8 years ago
You don't say exactly how and where the links and images are misplaced. Can you attach a screenshot of how it looks like in Firefox vs. what you expect to see in other browsers?

Comment 2

8 years ago
On 1 May 2010 13:55, Kevin T. Van <kevintvan@aol.com> wrote:
> Attached is what the issue is from what I'm seeing...I'm not sure how to fix
> it.

Please add your screenshots to the acutal bug. On the page:
<https://bugzilla.mozilla.org/show_bug.cgi?id=563121>

There is an attachment section. In that section there is a link:
"Add an attachment"

Cheers Phil
The reason for the layout issue--as best as I can tell--is the table to arrange the page.  There are two solutions I found from testing with Firebug.

First, to solve it temporarily, reduce the font size to 16px.  That removes the problem on Firefox Trunk (v. 3.7), anything larger breaks the table.

Second, in the long term, I would use divs rather than tables.  Since your layout is contained in a well-defined "box" with the elements staying in the same place, you can make use of absolute positioning; using something other than tables will dramatically increase interoperability between browsers and thus prevent future problems.

A theoretical, but unproven explanation would be that the table depends on a css definition that is not explicitly defined, but the definition is assumed correctly by the other browser rendering engines.  I don't know what that value is if that is the explanation, but possibly if it were defined in your css file, then the problem could be resolved.
(Reporter)

Comment 4

8 years ago
Created attachment 442899 [details]
Not right placement of images and links.

Works fine in other browsers! Not in Firefox....
(Reporter)

Comment 5

8 years ago
Using any font size doesn't matter, because it seems to only happen after the text passes a certain length on the page.

The div option didn't seem to work ether, unless I was doing it wrong.
Component: General → Page Info
OS: Windows Vista → All
Version: unspecified → 3.6 Branch

Comment 6

8 years ago
This bug has nothing to do with the PageInfo window.
Component: Page Info → General
Component: General → Layout
Keywords: testcase-wanted
Product: Firefox → Core
QA Contact: general → layout
Version: 3.6 Branch → 1.9.2 Branch
Looks like the site changed. I can't reproduce now with builds going back to 2008.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.