Nightly tools can't override compatibility issues of addons due to new Addon Manager

RESOLVED INVALID

Status

()

defect
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: divjot94, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100430 Firefox 3.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100430 Firefox 3.7

I recently thought to re install latest nigthly , in fact a clean fresh install. Now , i want to run stylish etc addons , but Nightly tester tool won't help for the new addon manager doesnt have "Over ride compatibility" button...

I hope you can understand

Reproducible: Always
Blocks: 550048
Its expected that addons like this (that modify the extension manager's behaviour) will break - its a completely re-written backend and frontend. The addon needs to be updated.

Note: The author of this particular addon is Mossop, who just happens to be the project lead for the new extension manager. So I now its on his to-do list.

However, to solve your immediate problem, you can override extension compatibility checking by using a hidden preference. See:
http://www.oxymoronical.com/blog/2009/11/Changing-the-checkCompatibility-preference
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.