While Internet Explorer notices 301 redirect, firefox doesn't.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Thomas Orschel, Unassigned)

Tracking

(Depends on: 1 bug)

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

301 redirect was done as follows:
'RedirectPermanent / http://thomasorschel.wordpress.com/patentrechtskanzlei-2/

Reproducible: Always

Steps to Reproduce:
1.enter http://www.patentrechtskanzlei in firefox
2.enter http://www.patentrechtskanzlei in internet explorer
3.you will see the diffrent results
Actual Results:  
the site http://thomasorschel.wordpress.com/ is shown by Firefox (noch correct)

the site http://thomasorschel.wordpress.com/patentrechtskanzlei-2/ appears when done with Internet Explorer (correct)

Expected Results:  
the site http://thomasorschel.wordpress.com/ is shown by Firefox (noch correct)

the site http://thomasorschel.wordpress.com/patentrechtskanzlei-2/ appears when done with Internet Explorer (correct)

Comment 1

8 years ago
Unable to replicate.
Please installed the addon Live HTTP Headers and dump the headers here.

Comment 2

8 years ago
unable to replicate due to malformed URL (unknown what TLD is required)
.de is the TLD as you can see in the URL field of the bug

wfm with Seamonkey trunk and FF3.6.4 on vista

Reporter:
301 Permanent redirects are cached. Is it possible that you had the wrong redirect enabled for a short time ?

Please clear the disk cache and if that doesn't help try a new profile
http://kb.mozillazine.org/Profile_Manager

Comment 4

8 years ago
ah, did not see the .de at the end of the url.. I must be getting blind or something. 
also: works for me under 3.6.3 under vista

Comment 5

8 years ago
WFM as well
This is the result with HTTPFox:
(Status-Line)	HTTP/1.1 301 Moved Permanently
Date	Sun, 02 May 2010 05:59:00 GMT
Server	Apache/2.2.15 (Unix)
Location	http://thomasorschel.wordpress.com/patentrechtskanzlei-2/
Content-Length	265
Keep-Alive	timeout=3, max=100
Connection	Keep-Alive
Content-Type	text/html; charset=iso-8859-1

Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.3a5pre) Gecko/20100501 Minefield/3.7a5pre - Build ID: 20100501040355

Updated

8 years ago
Version: unspecified → 3.6 Branch

Comment 6

8 years ago
Works for many. Unable to replicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Removing cached 301/302 that leads to errors might have fixed this, bug 688668.
Depends on: 688668
You need to log in before you can comment on or make changes to this bug.