warning: comparison between signed and unsigned integer expressions in nsHTMLFramesetFrame::RecalculateBorderResize()

RESOLVED DUPLICATE of bug 653295

Status

()

Core
Layout: HTML Frames
--
minor
RESOLVED DUPLICATE of bug 653295
8 years ago
5 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [build_warning])

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
layout/generic/nsFrameSetFrame.cpp: In member function ‘void nsHTMLFramesetFrame::RecalculateBorderResize()’:
1357: warning: comparison between signed and unsigned integer expressions
(Assignee)

Comment 1

8 years ago
Created attachment 442983 [details] [diff] [review]
proposal

i know, it's just one warning, but i really didn't like the variable types :)
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #442983 - Flags: review?(zweinberg)
Comment on attachment 442983 [details] [diff] [review]
proposal

Variables holding namespace IDs have to remain signed, because kNameSpaceID_UNKNOWN is -1.

Please file a bug on turning the mChildTypes constants in nsHTMLFramesetFrame into a proper enumeration.

Otherwise, looks good.
Attachment #442983 - Flags: review?(zweinberg) → review+
(Assignee)

Comment 3

8 years ago
Comment on attachment 442983 [details] [diff] [review]
proposal

i think i'm still working on this one
Attachment #442983 - Flags: review-

Updated

7 years ago
Whiteboard: [build_warning]

Updated

7 years ago
Blocks: 187528

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 653295
You need to log in before you can comment on or make changes to this bug.