Update addon version for AOM update testing (Mozilla QA Companion)

RESOLVED WONTFIX

Status

Other Applications
QA Companion
RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: kitchin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10pre) Gecko/20100501 Shiretoko/3.5.10pre
Build Identifier: Version 1.2.2

1. Need a new version compatible with "Firefox: 3.0 – 3.7a5pre", in order to test updating in the new Add-on Manager. The current version is compatible, but we need two versions working, one to update from and one to update to.

2.The update should include distinguishably new info in an updateInfoURL in the rdf (update.rdf?), to do the sort of testing recommended in Bug 395857. Then the update info will hopefully appear as the "Release notes" in the screenshot mockup here: https://wiki.mozilla.org/images/2/27/Manual_updates23432_case.png which is taken from https://wiki.mozilla.org/Firefox/Projects/Extension_Manager_Redesign/design#Upgrading_Existing_Add-on_.28from_AMO_or_other_Site.29


Reproducible: Always

Steps to Reproduce:
1. Wait for the new Addons Manager to re-land on trunk, or get a try build with it.
2. Install old version Mozilla QA Companion in Minefield.
3. Check for Addon updates.
4. Examine release notes in the Addons Manager for the new version of Mozilla QA Companion.

Actual Results:  
Fails at step 2 because none of the old versions are compatible with 3.7a5pre.

Expected Results:  
Distinguishably new info at Step 4.
(Reporter)

Comment 1

8 years ago
Changing title to include "Mozilla QA Companion". It is at version 1.2.2.
Summary: Update addon version for AOM update testing → Update addon version for AOM update testing (Mozilla QA Companion)
Created attachment 443010 [details] [diff] [review]
QAC maxVersion set to 3.7a5pre

Changed maxVersion to 3.7a5pre
Attachment #443010 - Flags: review?(harthur)

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Adblock Plus has two versions with 3.7a5pre compatibility: https://addons.mozilla.org/en-US/firefox/addons/versions/1865. 

Let me know if that's not what you need and maybe we can update QAC, but I'd rather not do an unnecessary update.
(Reporter)

Comment 4

8 years ago
Thanks, but it turns out the Adblock Plus web page at AMO is wrong. The old version will not install in Minefield, since contents.rdf actually has maxVersion 3.7a1pre. I filed a bug there: https://www.mozdev.org/bugs/show_bug.cgi?id=22806
Unfortunately, QAC would have that same problem (I updated the last version from AMO also), unless we wanted to push out two empty updates.
(In reply to comment #5)
> Unfortunately, QAC would have that same problem (I updated the last version
> from AMO also), unless we wanted to push out two empty updates.

I saw the version differentiation on AMO compared with the current version in repo, not sure if you wanted to take the patch for the minor adjustment for 3.7a5pre. In any case, if yes - it's attached above.
harthur ping?

Updated

7 years ago
Attachment #443010 - Attachment is obsolete: true
Attachment #443010 - Flags: review?(fayearthur+bugs)
old and and not needed
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.