Diff tool doesn't expand simple JAR file

RESOLVED FIXED in 6.0.7

Status

P4
minor
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: jorgev, Assigned: andy+bugzilla)

Tracking

unspecified
6.0.7

Details

(Whiteboard: [ReviewTeam], URL)

(Reporter)

Description

9 years ago
This file diff isn't expanding the JAR file in this add-on:
https://addons.mozilla.org/en-US/firefox/files/diff/87631/
And the View Source tool does show the JAR contents:
https://addons.mozilla.org/en-US/firefox/files/browse/87631/1

There are only a handful of code files there, and they are all very simple, so I don't see how this could be causing a memory error. It may be a bug in the diff code then.
Assignee: nobody → clouserw
The only .jar I found was chrome/chrome.jar so I assume that's what you're talking about, and this is working for me at both links.  Can you see if it's working for you now?
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

9 years ago
That's because the version was made public and the diff doesn't need to do this anymore.

I can still reproduce if I follow these steps:
1) Temporarily change the status of the latest version to pending review.
2) Open the diff page: https://addons.mozilla.org/en-US/firefox/files/diff/87631/
3) Try to open chrome.jar.

I haven't tested on preview because that version isn't present there, but it would be better to have it in preview instead of changing the status of the latest version back and forth.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
There is a check in the diff function that says "If the jar file doesn't exist in the previous version of the add-on, don't expand the jar file in the browser."

You're hitting that logic in this instance because the last "public" version of this add-on was in december and all the versions since have been "beta" which aren't checked against.
-> 4.x for dev tools rewrite
Target Milestone: 5.11 → 4.x (triaged)
I assume this is fixed with the new tools.  -> andym to verify
Assignee: clouserw → amckay
Target Milestone: 4.x (triaged) → Q2 2011
Target Milestone: Q2 2011 → 6.0.7
(Assignee)

Comment 6

8 years ago
I wasn't expanding .jar's inside the files, will add.
(Assignee)

Comment 7

8 years ago
https://github.com/jbalogh/zamboni/commit/0228a08265c533e9e2c3cba20007877202ddc291
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

7 years ago
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.