New compile warning: "format ‘%08x’ expects type ‘unsigned int’, but argument 3 has type ‘PtrBits’

RESOLVED FIXED

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: dholbert, Assigned: tnikkel)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [build_warning], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Bug 561010's changeset http://hg.mozilla.org/mozilla-central/rev/0ce6c931a05b introduced two new compile warnings, on x86 linux:
> content/base/src/nsGenericElement.cpp:4806: warning: format ‘%08x’ expects type ‘unsigned int’, but argument 3 has type ‘PtrBits’
> content/base/src/nsTextNode.cpp:239: warning: format ‘%08x’ expects type ‘unsigned int’, but argument 3 has type ‘PtrBits’

Timothy, mind investigating/fixing?
(Assignee)

Comment 1

9 years ago
Created attachment 443171 [details] [diff] [review]
patch
Assignee: nobody → tnikkel
Attachment #443171 - Flags: review?(jonas)
(Reporter)

Updated

9 years ago
Whiteboard: [build_warning]
(Assignee)

Comment 2

9 years ago
Landed
http://hg.mozilla.org/mozilla-central/rev/116e56d84770

but backed out because something in the push was causing orange
http://hg.mozilla.org/mozilla-central/rev/01befa5163ee
(Reporter)

Updated

9 years ago
Duplicate of this bug: 564847
(Assignee)

Comment 4

9 years ago
http://hg.mozilla.org/mozilla-central/rev/7ec3d8b1517c
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.