Message Pane reappears and Search filter resets to "Search All Messages" on restart

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: bnulman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Thunderbird/3.0.4

I have the message pane turned off, and I set the Search filter to "Subject, From, or Recipient". Oftentimes (but not every time) when I close Thunderbird and start it up again, the Message Pane will be turned on again, and the Search filter reset to "Search All Messages". I suspect this happens when Thunderbird doesn't close properly. I can reproduce this problem 100% of the time if I kill the thunderbird.exe process from Task Manager.

Reproducible: Always

Steps to Reproduce:
1.Turn off message pane
2.Select any search filter other than "Search all messages"
3.Kill the thunderbird.exe process from Task Manager
4.Restart Thunderbird
Actual Results:  
Message pane is back on. Search filter is reset to "Search All Messages"

Expected Results:  
Message pane should be off. Search filter should be whatever was previously selected. (In other words, settings should be maintained despite the improper close.)
(Reporter)

Comment 1

8 years ago
Also noticed that the expanded/collapsed state of the folders in the folder list is reset as well when the bug occurs (which is every time thunderbird isn't closed properly). For example, I generally have two email accounts fully expanded in the folder list, while 3 accounts are just listed by account name. when i kill thunderbird via task manager and then restart, all but one email accounts are fully expanded.
The rule is to have one issue per bug, this sounds like 2 or 3.

The message pane problem is bug 518345

The search choice has been fixed in 3.1.b2

I'm pretty sure that we have the columns somewhere in bugzilla already (please do the search and open that specific bug if you can't find it).

I'm going to close this bug as invalid - because it contains 2 known issue (and potentially a third known one) - to start tracking the potential last bug on clean bases.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.