TM: maintain code cache per global object

RESOLVED DUPLICATE of bug 584860

Status

()

Core
JavaScript Engine
P2
normal
RESOLVED DUPLICATE of bug 584860
8 years ago
7 years ago

People

(Reporter: gal, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Reporter)

Description

8 years ago
We have code allocs now. We could probably give content and chrome their own code allocs, or even one code alloc per window.
(Reporter)

Updated

8 years ago
Summary: TM: content blows away code cache, affecting other windows and chrome too → TM: maintain code cache per global object
Note that this could be a big perf win -- right now we blow away all the generated code chunks extremely frequently (like at least once per page load, any page load, we blow away the whole thing for the entire runtime).
blocking2.0: --- → ?

Updated

8 years ago
blocking2.0: ? → final+
(Reporter)

Updated

8 years ago
OS: Mac OS X → All
Priority: -- → P2
Hardware: x86 → All
What's the status on this bug? Is it still meaningful? Do we still need it for Fx4?
(Reporter)

Comment 3

7 years ago
We have a bug we must fix for ff4 to do it per compartment. We can dup this one.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584860
You need to log in before you can comment on or make changes to this bug.